gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / superlu-dist-awpm-grid.patch
1 Create the CombBLAS::SpParMat with the MPI_Comm from the input 'gridinfo_t'.
2 This prevents a warning/error from CombBLAS about using MPI_COMM_WORLD.
3
4 --- a/SRC/dHWPM_CombBLAS.hpp
5 +++ b/SRC/dHWPM_CombBLAS.hpp
6 @@ -52,7 +52,7 @@
7 {
8 printf("AWPM only supports square process grid. Retuning without a permutation.\n");
9 }
10 - combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc;
11 + combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc(grid->comm);
12 std::vector< std::vector < std::tuple<int_t,int_t,double> > > data(procs);
13
14 /* ------------------------------------------------------------
15 --- a/SRC/zHWPM_CombBLAS.hpp
16 +++ b/SRC/zHWPM_CombBLAS.hpp
17 @@ -52,7 +52,7 @@
18 {
19 printf("AWPM only supports square process grid. Retuning without a permutation.\n");
20 }
21 - combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc;
22 + combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc(grid->comm);
23 std::vector< std::vector < std::tuple<int_t,int_t,double> > > data(procs);
24
25 /* ------------------------------------------------------------