gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / sssd-fix-samba.patch
1 From bc56b10aea999284458dcc293b54cf65288e325d Mon Sep 17 00:00:00 2001
2 From: Stephen Gallagher <sgallagh@redhat.com>
3 Date: Fri, 24 Jan 2020 15:17:39 +0100
4 Subject: [PATCH] Fix build failure against samba 4.12.0rc1
5 MIME-Version: 1.0
6 Content-Type: text/plain; charset=UTF-8
7 Content-Transfer-Encoding: 8bit
8
9 The ndr_pull_get_switch() function was dropped, but it was just a wrapper
10 around the ndr_token_peek() function, so we can use this approach on both
11 old and new versions of libndr.
12
13 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
14
15 Reviewed-by: Pavel Březina <pbrezina@redhat.com>
16 ---
17 src/providers/ad/ad_gpo_ndr.c | 6 +++---
18 1 file changed, 3 insertions(+), 3 deletions(-)
19
20 diff --git a/src/providers/ad/ad_gpo_ndr.c b/src/providers/ad/ad_gpo_ndr.c
21 index d573033494..8f405aa62b 100644
22 --- a/src/providers/ad/ad_gpo_ndr.c
23 +++ b/src/providers/ad/ad_gpo_ndr.c
24 @@ -105,7 +105,7 @@ ndr_pull_security_ace_object_type(struct ndr_pull *ndr,
25 union security_ace_object_type *r)
26 {
27 uint32_t level;
28 - level = ndr_pull_get_switch_value(ndr, r);
29 + level = ndr_token_peek(&ndr->switch_list, r);
30 NDR_PULL_CHECK_FLAGS(ndr, ndr_flags);
31 if (ndr_flags & NDR_SCALARS) {
32 NDR_CHECK(ndr_pull_union_align(ndr, 4));
33 @@ -135,7 +135,7 @@ ndr_pull_security_ace_object_inherited_type(struct ndr_pull *ndr,
34 union security_ace_object_inherited_type *r)
35 {
36 uint32_t level;
37 - level = ndr_pull_get_switch_value(ndr, r);
38 + level = ndr_token_peek(&ndr->switch_list, r);
39 NDR_PULL_CHECK_FLAGS(ndr, ndr_flags);
40 if (ndr_flags & NDR_SCALARS) {
41 NDR_CHECK(ndr_pull_union_align(ndr, 4));
42 @@ -198,7 +198,7 @@ ndr_pull_security_ace_object_ctr(struct ndr_pull *ndr,
43 union security_ace_object_ctr *r)
44 {
45 uint32_t level;
46 - level = ndr_pull_get_switch_value(ndr, r);
47 + level = ndr_token_peek(&ndr->switch_list, r);
48 NDR_PULL_CHECK_FLAGS(ndr, ndr_flags);
49 if (ndr_flags & NDR_SCALARS) {
50 NDR_CHECK(ndr_pull_union_align(ndr, 4));