gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / shishi-fix-libgcrypt-detection.patch
1 Fix building of Shishi with libgcrypt 1.6 and later.
2
3 Patch copied from Debian:
4
5 https://anonscm.debian.org/cgit/collab-maint/shishi.git/tree/debian/patches/fix_gcrypt_detection.diff?id=948301ae648a542a408da250755aeed58a6e3542
6
7 Description: Fix autoconf gnutls detection to also accept gcrypt 1.6.
8 Author: Andreas Metzler <ametzler@debian.org>
9 Bug-Debian: http://bugs.debian.org/753150
10 Origin: vendor
11 Forwarded: no
12 Last-Update: 2014-07-18
13
14 --- shishi-1.0.2.orig/gl/m4/gc.m4
15 +++ shishi-1.0.2/gl/m4/gc.m4
16 @@ -12,10 +12,12 @@ AC_DEFUN([gl_GC],
17 if test "$libgcrypt" != no; then
18 AC_LIB_HAVE_LINKFLAGS([gcrypt], [gpg-error], [
19 #include <gcrypt.h>
20 -/* GCRY_MODULE_ID_USER was added in 1.4.4 and gc-libgcrypt.c
21 - will fail on startup if we don't have 1.4.4 or later, so
22 - test for it early. */
23 -#if !defined GCRY_MODULE_ID_USER
24 +/* gc-libgcrypt.c will fail on startup if we don't have libgcrypt 1.4.4 or
25 + later, test for it early. by checking for either
26 + - GCRY_MODULE_ID_USER which was added in 1.4.4 and dropped in 1.6 or
27 + - GCRYPT_VERSION_NUMBER which was added in 1.6.
28 + */
29 +#if !defined GCRY_MODULE_ID_USER && !defined GCRYPT_VERSION_NUMBER
30 error too old libgcrypt
31 #endif
32 ])