gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / screen-hurd-path-max.patch
1 Workaround for PATH_MAX usage on the Hurd.
2
3 Taken from https://salsa.debian.org/debian/screen/-/blob/master/debian/patches/61-default-PATH_MAX-if-undefined-for-hurd.patch
4
5 Description: Set PATH_MAX to 4096 if undefined
6 Fixes FTBFS since 4.4.0 on GNU/Hurd. Updated to add one more occurrence for 4.5.0.
7 Author: Axel Beckert <abe@debian.org>
8 Bug: https://savannah.gnu.org/bugs/?50089
9 Last-Updated: 2017-01-18
10
11 --- a/tty.sh
12 +++ b/tty.sh
13 @@ -1478,6 +1478,13 @@
14 return 0;
15 }
16
17 +/*
18 + * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
19 + */
20 +
21 +#ifndef PATH_MAX
22 +#define PATH_MAX 4096
23 +#endif
24
25 int CheckTtyname (char *tty)
26 {
27 --- a/screen.h
28 +++ b/screen.h
29 @@ -109,6 +109,13 @@
30 # define DEFAULT_BUFFERFILE "/tmp/screen-exchange"
31 #endif
32
33 +/*
34 + * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
35 + */
36 +
37 +#ifndef PATH_MAX
38 +#define PATH_MAX 4096
39 +#endif
40
41 #if defined(hpux) && !(defined(VSUSP) && defined(VDSUSP) && defined(VWERASE) && defined(VLNEXT))
42 # define HPUX_LTCHARS_HACK