gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / sbc-fix-build-non-x86.patch
1 Don't refer to x86-specific function on other architectures to avoid linker error.
2
3 Submitted upstream at <https://marc.info/?l=linux-bluetooth&m=160857625608440&w=2>
4
5 diff --git a/sbc/sbc_primitives.c b/sbc/sbc_primitives.c
6 --- a/sbc/sbc_primitives.c
7 +++ b/sbc/sbc_primitives.c
8 @@ -593,7 +593,9 @@ static int sbc_calc_scalefactors_j(
9
10 static void sbc_init_primitives_x86(struct sbc_encoder_state *state)
11 {
12 +#if defined(__x86_64__) || defined(__i386__)
13 __builtin_cpu_init();
14 +#endif
15
16 #ifdef SBC_BUILD_WITH_MMX_SUPPORT
17 if (__builtin_cpu_supports("mmx"))