gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / samba-fix-fcntl-hint-detection.patch
1 From 454ccd986b61799908a6898a55d0480911f15306 Mon Sep 17 00:00:00 2001
2 From: Ralph Boehme <slow@samba.org>
3 Date: Mon, 21 Sep 2020 07:48:43 +0200
4 Subject: [PATCH] s3: fix fcntl waf configure check
5
6 RN: Fix fcntl waf configure check
7 BUG: https://bugzilla.samba.org/show_bug.cgi?id=14503
8
9 Signed-off-by: Ralph Boehme <slow@samba.org>
10 Reviewed-by: Volker Lendecke <vl@samba.org>
11
12 Autobuild-User(master): Volker Lendecke <vl@samba.org>
13 Autobuild-Date(master): Mon Sep 21 07:26:54 UTC 2020 on sn-devel-184
14 ---
15 source3/wscript | 10 +++++-----
16 1 file changed, 5 insertions(+), 5 deletions(-)
17
18 diff --git a/source3/wscript b/source3/wscript
19 index 840ed430c0f..d3ef346eecd 100644
20 --- a/source3/wscript
21 +++ b/source3/wscript
22 @@ -1244,7 +1244,7 @@ err:
23
24 int main(void)
25 {
26 - uint64_t *hint, get_hint;
27 + uint64_t hint, get_hint;
28 int fd;
29
30 fd = open(DATA, O_RDONLY | O_CREAT | O_EXCL);
31 @@ -1252,8 +1252,8 @@ int main(void)
32 goto err;
33 }
34
35 - *hint = RWH_WRITE_LIFE_SHORT;
36 - int ret = fcntl(fd, F_SET_RW_HINT, hint);
37 + hint = RWH_WRITE_LIFE_SHORT;
38 + int ret = fcntl(fd, F_SET_RW_HINT, &hint);
39 if (ret == -1) {
40 goto err;
41 }
42 @@ -1267,8 +1267,8 @@ int main(void)
43 goto err;
44 }
45
46 - *hint = RWH_WRITE_LIFE_EXTREME;
47 - ret = fcntl(fd, F_SET_FILE_RW_HINT, hint);
48 + hint = RWH_WRITE_LIFE_EXTREME;
49 + ret = fcntl(fd, F_SET_FILE_RW_HINT, &hint);
50 if (ret == -1) {
51 goto err;
52 }
53 --
54 2.28.0
55