gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / rpcbind-CVE-2017-8779.patch
1 Fix CVE-2017-8779:
2
3 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8779
4
5 Patch copied from the bug reporter's 3rd-party repository:
6
7 https://github.com/guidovranken/rpcbomb/blob/master/rpcbind_patch.txt
8
9 diff --git a/src/rpcb_svc_com.c b/src/rpcb_svc_com.c
10 index 5862c26..e11f61b 100644
11 --- a/src/rpcb_svc_com.c
12 +++ b/src/rpcb_svc_com.c
13 @@ -48,6 +48,7 @@
14 #include <rpc/rpc.h>
15 #include <rpc/rpcb_prot.h>
16 #include <rpc/svc_dg.h>
17 +#include <rpc/rpc_com.h>
18 #include <netconfig.h>
19 #include <errno.h>
20 #include <syslog.h>
21 @@ -432,7 +433,7 @@ rpcbproc_taddr2uaddr_com(void *arg, struct svc_req *rqstp /*__unused*/,
22 static bool_t
23 xdr_encap_parms(XDR *xdrs, struct encap_parms *epp)
24 {
25 - return (xdr_bytes(xdrs, &(epp->args), (u_int *) &(epp->arglen), ~0));
26 + return (xdr_bytes(xdrs, &(epp->args), (u_int *) &(epp->arglen), RPC_MAXDATASIZE));
27 }
28
29 /*