gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / readline-link-ncurses.patch
1 This patch is to make sure that `libncurses' is among the `NEEDED'
2 dependencies of `libreadline.so' and `libhistory.so'.
3
4 Failing to do that, applications linking against Readline are
5 forced to explicitly link against libncurses as well; in addition,
6 this trick doesn't work when using GNU ld's `--as-needed'.
7
8 --- shlib/Makefile.in 2009-01-06 18:03:22.000000000 +0100
9 +++ shlib/Makefile.in 2009-07-27 14:43:25.000000000 +0200
10 @@ -84,7 +84,7 @@ SHOBJ_LDFLAGS = @SHOBJ_LDFLAGS@
11 SHOBJ_XLDFLAGS = @SHOBJ_XLDFLAGS@
12 SHOBJ_LIBS = @SHOBJ_LIBS@
13
14 -SHLIB_XLDFLAGS = @LDFLAGS@ @SHLIB_XLDFLAGS@
15 +SHLIB_XLDFLAGS = @LDFLAGS@ @SHLIB_XLDFLAGS@ -lncurses
16 SHLIB_LIBS = @SHLIB_LIBS@
17
18 SHLIB_DOT = @SHLIB_DOT@