gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / python2-subprocess32-disable-input-test.patch
1 This test tries to send a KeyboardInterrupt, which does
2 not work in the build environment.
3
4 --- a/test_subprocess32.py 2017-03-06 22:21:49.334045485 +0100
5 +++ b/test_subprocess32.py 2017-03-06 22:22:02.490439949 +0100
6 @@ -1299,12 +1299,6 @@
7 getattr(p, method)(*args)
8 return p
9
10 - def test_send_signal(self):
11 - p = self._kill_process('send_signal', signal.SIGINT)
12 - _, stderr = p.communicate()
13 - self.assertIn('KeyboardInterrupt', stderr)
14 - self.assertNotEqual(p.wait(), 0)
15 -
16 def test_kill(self):
17 p = self._kill_process('kill')
18 _, stderr = p.communicate()