gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / python-memcached-syntax-warnings.patch
1 Problem reported upstream:
2 https://github.com/linsomniac/python-memcached/issues/176
3
4 ---
5 memcache.py | 4 ++--
6 1 file changed, 2 insertions(+), 2 deletions(-)
7
8 diff --git a/memcache.py b/memcache.py
9 index 05b6657..b935681 100644
10 --- a/memcache.py
11 +++ b/memcache.py
12 @@ -1300,8 +1300,8 @@ class Client(threading.local):
13 key = key[1]
14 if key is None:
15 raise Client.MemcachedKeyNoneError("Key is None")
16 - if key is '':
17 - if key_extra_len is 0:
18 + if key == '':
19 + if key_extra_len == 0:
20 raise Client.MemcachedKeyNoneError("Key is empty")
21
22 # key is empty but there is some other component to key
23 --
24 2.26.2