gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / python-flint-includes.patch
1 The following patch, authored by Andreas Enge, looks for the flint include
2 files in the correct subdirectory.
3
4 diff -u -r python-flint-old/src/flint.pxd python-flint-new/src/flint.pxd
5 --- python-flint-old/src/flint.pxd 2019-03-19 10:26:11.055748626 +0100
6 +++ python-flint-new/src/flint.pxd 2019-03-19 10:35:23.269341203 +0100
7 @@ -27,7 +27,7 @@
8
9 ctypedef long fmpz_struct
10
11 -cdef extern from "flint.h":
12 +cdef extern from "flint/flint.h":
13 ctypedef void * flint_rand_t
14 void flint_randinit(flint_rand_t state)
15 void flint_randclear(flint_rand_t state)
16 @@ -35,7 +35,7 @@
17 long flint_get_num_threads()
18 void flint_cleanup()
19
20 -cdef extern from "nmod_vec.h":
21 +cdef extern from "flint/nmod_vec.h":
22 ctypedef struct nmod_t:
23 mp_limb_t n
24 mp_limb_t ninv
25 @@ -47,7 +47,7 @@
26 mp_limb_t nmod_mul(mp_limb_t a, mp_limb_t b, nmod_t mod)
27 mp_limb_t nmod_div(mp_limb_t a, mp_limb_t b, nmod_t mod)
28
29 -cdef extern from "nmod_poly.h":
30 +cdef extern from "flint/nmod_poly.h":
31 ctypedef struct nmod_poly_struct:
32 mp_ptr coeffs
33 long alloc
34 @@ -129,7 +129,7 @@
35 void nmod_poly_factor_init(nmod_poly_factor_t fac)
36 void nmod_poly_factor_clear(nmod_poly_factor_t fac)
37
38 -cdef extern from "nmod_mat.h":
39 +cdef extern from "flint/nmod_mat.h":
40 ctypedef struct nmod_mat_struct:
41 mp_limb_t * entries
42 long r
43 @@ -178,7 +178,7 @@
44 long nmod_mat_rref(nmod_mat_t A)
45 long nmod_mat_nullspace(nmod_mat_t X, nmod_mat_t A)
46
47 -cdef extern from "fmpz.h":
48 +cdef extern from "flint/fmpz.h":
49 ctypedef fmpz_struct fmpz_t[1]
50 int COEFF_IS_MPZ(fmpz_struct v)
51 void fmpz_init(fmpz_t op)
52 @@ -268,7 +268,7 @@
53 void fmpz_rfac_uiui(fmpz_t r, ulong x, ulong n)
54 void fmpz_primorial(fmpz_t res, ulong n)
55
56 -cdef extern from "fmpz_factor.h":
57 +cdef extern from "flint/fmpz_factor.h":
58 ctypedef struct fmpz_factor_struct:
59 int sign
60 fmpz_struct * p
61 @@ -280,7 +280,7 @@
62 void fmpz_factor_clear(fmpz_factor_t factor)
63 void fmpz_factor(fmpz_factor_t factor, fmpz_t n)
64
65 -cdef extern from "fmpz_poly.h":
66 +cdef extern from "flint/fmpz_poly.h":
67 ctypedef struct fmpz_poly_struct:
68 fmpz_struct * coeffs
69 long alloc
70 @@ -390,14 +390,14 @@
71 void fmpz_poly_cos_minpoly(fmpz_poly_t, ulong)
72 void fmpz_poly_swinnerton_dyer(fmpz_poly_t, ulong)
73
74 -cdef extern from "fmpz_poly_factor.h":
75 +cdef extern from "flint/fmpz_poly_factor.h":
76 void fmpz_poly_factor_init(fmpz_poly_factor_t fac)
77 void fmpz_poly_factor_clear(fmpz_poly_factor_t fac)
78 void fmpz_poly_factor_zassenhaus(fmpz_poly_factor_t fac, fmpz_poly_t G)
79 void fmpz_poly_factor(fmpz_poly_factor_t fac, fmpz_poly_t G)
80 void fmpz_poly_factor_squarefree(fmpz_poly_factor_t fac, fmpz_poly_t G)
81
82 -cdef extern from "fmpz_mat.h":
83 +cdef extern from "flint/fmpz_mat.h":
84 ctypedef struct fmpz_mat_struct:
85 fmpz_struct * entries
86 long r
87 @@ -448,7 +448,7 @@
88 void fmpz_mat_snf(fmpz_mat_t S, const fmpz_mat_t A)
89 int fmpz_mat_is_in_snf(const fmpz_mat_t A)
90
91 -cdef extern from "fmpz_lll.h":
92 +cdef extern from "flint/fmpz_lll.h":
93 ctypedef struct fmpz_lll_struct:
94 double delta
95 double eta
96 @@ -461,7 +461,7 @@
97 void fmpz_lll(fmpz_mat_t B, fmpz_mat_t U, const fmpz_lll_t fl)
98
99
100 -cdef extern from "fmpq.h":
101 +cdef extern from "flint/fmpq.h":
102 ctypedef struct fmpq_struct:
103 fmpz_struct num
104 fmpz_struct den
105 @@ -506,7 +506,7 @@
106 void fmpq_next_signed_minimal(fmpq_t res, fmpq_t x)
107 void fmpq_harmonic_ui(fmpq_t res, ulong n)
108
109 -cdef extern from "fmpq_poly.h":
110 +cdef extern from "flint/fmpq_poly.h":
111 ctypedef struct fmpq_poly_struct:
112 fmpz_struct * coeffs
113 fmpz_t den
114 @@ -620,7 +620,7 @@
115 void fmpq_poly_compose_series(fmpq_poly_t res, fmpq_poly_t poly1, fmpq_poly_t poly2, long n)
116 void fmpq_poly_revert_series(fmpq_poly_t res, fmpq_poly_t poly1, long n)
117
118 -cdef extern from "fmpq_mat.h":
119 +cdef extern from "flint/fmpq_mat.h":
120 ctypedef struct fmpq_mat_struct:
121 fmpq_struct * entries
122 long r
123 @@ -672,7 +672,7 @@
124 long fmpq_mat_rref(fmpq_mat_t B, fmpq_mat_t A)
125 void fmpq_mat_transpose(fmpq_mat_t B, fmpq_mat_t A)
126
127 -cdef extern from "arith.h":
128 +cdef extern from "flint/arith.h":
129 void arith_number_of_partitions(fmpz_t res, ulong n)
130 int arith_moebius_mu(fmpz_t n)
131 void arith_divisor_sigma(fmpz_t v, fmpz_t n, ulong k)