gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / python-configobj-setuptools.patch
1 From 16fbc38f13e435b4e3e1a37d706e64e05bad4691 Mon Sep 17 00:00:00 2001
2 From: Leo Famulari <leo@famulari.name>
3 Date: Tue, 10 Nov 2015 23:09:24 -0500
4 Subject: [PATCH] patch build to use setuptools
5
6 ---
7 setup.py | 8 +++++++-
8 1 file changed, 7 insertions(+), 1 deletion(-)
9
10 diff --git a/setup.py b/setup.py
11 index c6d57a6..27bf260 100644
12 --- a/setup.py
13 +++ b/setup.py
14 @@ -12,7 +12,12 @@
15 # http://opensource.org/licenses/BSD-3-Clause
16 import os
17 import sys
18 -from distutils.core import setup
19 +
20 +try:
21 + from setuptools import setup
22 +except ImportError:
23 + from distutils.core import setup
24 +
25 # a simple import wouldn't work if we moved towards a package with __init__
26 from _version import __version__
27
28 --
29 2.6.2
30