gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / python-2.7-adjust-tests.patch
1 SIGINT is ignored in the Guix build environment.
2
3 --- a/Lib/test/test_regrtest.py
4 +++ b/Lib/test/test_regrtest.py
5 @@ -399,6 +399,8 @@
6 output = self.run_tests('--fromfile', filename)
7 self.check_executed_tests(output, tests)
8
9 + @unittest.skipIf(True,
10 + "KeyboardInterrupts do not work in the build environment")
11 def test_interrupted(self):
12 code = TEST_INTERRUPTED
13 test = self.create_test('sigint', code=code)
14 @@ -416,6 +418,8 @@
15 % (self.TESTNAME_REGEX, len(tests)))
16 self.check_line(output, regex)
17
18 + @unittest.skipIf(True,
19 + "KeyboardInterrupts do not work in the build environment")
20 def test_slow_interrupted(self):
21 # Issue #25373: test --slowest with an interrupted test
22 code = TEST_INTERRUPTED