gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / python-2-deterministic-build-info.patch
1 Always provide the same date and time in 'Py_GetBuildInfo'.
2 This is the information shown at the REPL and in 'sys.version'.
3 We cannot pass it in CPPFLAGS due to whitespace in the DATE string.
4
5 --- a/Modules/getbuildinfo.c
6 +++ b/Modules/getbuildinfo.c
7 @@ -4,6 +4,10 @@
8 #include <stdio.h>
9 #endif
10
11 +/* Deterministic date and time. */
12 +#define DATE "Jan 1 1970"
13 +#define TIME "00:00:01"
14 +
15 #ifndef DATE
16 #ifdef __DATE__
17 #define DATE __DATE__