gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / purescript-relax-dependencies.patch
1 Allow the purescript dependencies to better match the available packages in
2 Guix.
3
4 --- purescript-0.13.8/purescript.cabal
5 +++ purescript-0.13.8/purescript.cabal.orig
6 @@ -1091 +1091 @@ library
7 - Glob ==0.9.*,
8 + Glob ==0.10.*,
9 @@ -1095 +1095 @@ library
10 - ansi-terminal >=0.7.1 && <0.9,
11 + ansi-terminal ==0.9.*,
12 @@ -1105 +1105 @@ library
13 - clock <0.8,
14 + clock ==0.8.*,
15 @@ -1173 +1173 @@ executable purs
16 - Glob ==0.9.*,
17 + Glob ==0.10.*,
18 @@ -1177 +1177 @@ executable purs
19 - ansi-terminal >=0.7.1 && <0.9,
20 + ansi-terminal ==0.9.*,
21 @@ -1188 +1188 @@ executable purs
22 - clock <0.8,
23 + clock ==0.8.*,
24 @@ -1209 +1209 @@ executable purs
25 - network >=3.0.1.1 && <3.1,
26 + network >=2.8 && <3.1,
27 @@ -1288 +1288 @@ test-suite tests
28 - Glob ==0.9.*,
29 + Glob ==0.10.*,
30 @@ -1293 +1293 @@ test-suite tests
31 - ansi-terminal >=0.7.1 && <0.9,
32 + ansi-terminal ==0.9.*,
33 @@ -1303 +1303 @@ test-suite tests
34 - clock <0.8,
35 + clock ==0.8.*,
36 @@ -1315,2 +1315,2 @@ test-suite tests
37 - hspec <2.7,
38 - hspec-discover <2.7,
39 + hspec ==2.7.*,
40 + hspec-discover ==2.7.*,