gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ppsspp-disable-upgrade-and-gold.patch
1 From 0c57874ebb5982154da127ae338f9190b1581804 Mon Sep 17 00:00:00 2001
2 From: Leo Prikler <leo.prikler@student.tugraz.at>
3 Date: Fri, 26 Jun 2020 18:20:04 +0200
4 Subject: [PATCH] ppsspp: disable upgrade and gold
5
6 ---
7 Core/Config.cpp | 11 ------
8 Core/Config.h | 2 --
9 Qt/QtMain.cpp | 6 ----
10 SDL/SDLMain.cpp | 6 ----
11 UI/DevScreens.cpp | 3 --
12 UI/GameSettingsScreen.cpp | 1 -
13 UI/MainScreen.cpp | 70 +------------------------------------
14 UI/MiscScreens.cpp | 31 ++--------------
15 UWP/PPSSPP_UWPMain.cpp | 6 ----
16 Windows/MainWindowMenu.cpp | 2 +-
17 Windows/main.cpp | 6 ----
18 android/jni/app-android.cpp | 6 ----
19 12 files changed, 5 insertions(+), 145 deletions(-)
20
21 diff --git a/Core/Config.cpp b/Core/Config.cpp
22 index 1c53e8e57..2fa74a6b8 100644
23 --- a/Core/Config.cpp
24 +++ b/Core/Config.cpp
25 @@ -439,7 +439,6 @@ static ConfigSetting generalSettings[] = {
26 ConfigSetting("IgnoreBadMemAccess", &g_Config.bIgnoreBadMemAccess, true, true),
27 ConfigSetting("CurrentDirectory", &g_Config.currentDirectory, ""),
28 ConfigSetting("ShowDebuggerOnLoad", &g_Config.bShowDebuggerOnLoad, false),
29 - ConfigSetting("CheckForNewVersion", &g_Config.bCheckForNewVersion, true),
30 ConfigSetting("Language", &g_Config.sLanguageIni, &DefaultLangRegion),
31 ConfigSetting("ForceLagSync2", &g_Config.bForceLagSync, false, true, true),
32 ConfigSetting("DiscordPresence", &g_Config.bDiscordPresence, true, true, false), // Or maybe it makes sense to have it per-game? Race conditions abound...
33 @@ -1293,16 +1292,6 @@ void Config::Load(const char *iniFileName, const char *controllerIniFilename) {
34 upgradeMessage = "";
35 }
36
37 - // Check for new version on every 10 runs.
38 - // Sometimes the download may not be finished when the main screen shows (if the user dismisses the
39 - // splash screen quickly), but then we'll just show the notification next time instead, we store the
40 - // upgrade number in the ini.
41 - if (iRunCount % 10 == 0 && bCheckForNewVersion) {
42 - std::shared_ptr<http::Download> dl = g_DownloadManager.StartDownloadWithCallback(
43 - "http://www.ppsspp.org/version.json", "", &DownloadCompletedCallback);
44 - dl->SetHidden(true);
45 - }
46 -
47 INFO_LOG(LOADER, "Loading controller config: %s", controllerIniFilename_.c_str());
48 bSaveSettings = true;
49
50 diff --git a/Core/Config.h b/Core/Config.h
51 index 13bce8a36..70d6c8aaf 100644
52 --- a/Core/Config.h
53 +++ b/Core/Config.h
54 @@ -101,7 +101,6 @@ struct Config {
55
56 bool bFastMemory;
57 int iCpuCore;
58 - bool bCheckForNewVersion;
59 bool bForceLagSync;
60 bool bFuncReplacements;
61 bool bHideSlowWarnings;
62 @@ -540,4 +539,3 @@ std::string CreateRandMAC();
63 // TODO: Find a better place for this.
64 extern http::Downloader g_DownloadManager;
65 extern Config g_Config;
66 -
67 diff --git a/Qt/QtMain.cpp b/Qt/QtMain.cpp
68 index 5be0cefa0..b11cb1c64 100644
69 --- a/Qt/QtMain.cpp
70 +++ b/Qt/QtMain.cpp
71 @@ -218,12 +218,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
72 case SYSPROP_HAS_FILE_BROWSER:
73 case SYSPROP_HAS_FOLDER_BROWSER:
74 return true;
75 - case SYSPROP_APP_GOLD:
76 -#ifdef GOLD
77 - return true;
78 -#else
79 - return false;
80 -#endif
81 default:
82 return false;
83 }
84 diff --git a/SDL/SDLMain.cpp b/SDL/SDLMain.cpp
85 index 98b56fe91..6af0fcb1a 100644
86 --- a/SDL/SDLMain.cpp
87 +++ b/SDL/SDLMain.cpp
88 @@ -380,12 +380,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
89 switch (prop) {
90 case SYSPROP_HAS_BACK_BUTTON:
91 return true;
92 - case SYSPROP_APP_GOLD:
93 -#ifdef GOLD
94 - return true;
95 -#else
96 - return false;
97 -#endif
98 default:
99 return false;
100 }
101 diff --git a/UI/DevScreens.cpp b/UI/DevScreens.cpp
102 index 8daac5bc8..c0c09ce79 100644
103 --- a/UI/DevScreens.cpp
104 +++ b/UI/DevScreens.cpp
105 @@ -605,9 +605,6 @@ void SystemInfoScreen::CreateViews() {
106 #ifdef _M_SSE
107 buildConfig->Add(new InfoItem("_M_SSE", StringFromFormat("0x%x", _M_SSE)));
108 #endif
109 - if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
110 - buildConfig->Add(new InfoItem("GOLD", ""));
111 - }
112
113 ViewGroup *cpuExtensionsScroll = new ScrollView(ORIENT_VERTICAL, new LinearLayoutParams(FILL_PARENT, FILL_PARENT));
114 cpuExtensionsScroll->SetTag("DevSystemInfoCPUExt");
115 diff --git a/UI/GameSettingsScreen.cpp b/UI/GameSettingsScreen.cpp
116 index 2f1e157ee..38c586b06 100644
117 --- a/UI/GameSettingsScreen.cpp
118 +++ b/UI/GameSettingsScreen.cpp
119 @@ -914,7 +914,6 @@ void GameSettingsScreen::CreateViews() {
120 }
121 }
122 #endif
123 - systemSettings->Add(new CheckBox(&g_Config.bCheckForNewVersion, sy->T("VersionCheck", "Check for new versions of PPSSPP")));
124 const std::string bgPng = GetSysDirectory(DIRECTORY_SYSTEM) + "background.png";
125 const std::string bgJpg = GetSysDirectory(DIRECTORY_SYSTEM) + "background.jpg";
126 if (File::Exists(bgPng) || File::Exists(bgJpg)) {
127 diff --git a/UI/MainScreen.cpp b/UI/MainScreen.cpp
128 index ca870ab8f..84cde88ac 100644
129 --- a/UI/MainScreen.cpp
130 +++ b/UI/MainScreen.cpp
131 @@ -1064,11 +1064,7 @@ void MainScreen::CreateViews() {
132 sprintf(versionString, "%s", PPSSPP_GIT_VERSION);
133 rightColumnItems->SetSpacing(0.0f);
134 AnchorLayout *logos = new AnchorLayout(new AnchorLayoutParams(FILL_PARENT, 60.0f, false));
135 - if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
136 - logos->Add(new ImageView(ImageID("I_ICONGOLD"), IS_DEFAULT, new AnchorLayoutParams(64, 64, 0, 0, NONE, NONE, false)));
137 - } else {
138 - logos->Add(new ImageView(ImageID("I_ICON"), IS_DEFAULT, new AnchorLayoutParams(64, 64, 0, 0, NONE, NONE, false)));
139 - }
140 + logos->Add(new ImageView(ImageID("I_ICON"), IS_DEFAULT, new AnchorLayoutParams(64, 64, 0, 0, NONE, NONE, false)));
141 logos->Add(new ImageView(ImageID("I_LOGO"), IS_DEFAULT, new AnchorLayoutParams(180, 64, 64, -5.0f, NONE, NONE, false)));
142
143 #if !defined(MOBILE_DEVICE)
144 @@ -1089,11 +1085,6 @@ void MainScreen::CreateViews() {
145 rightColumnItems->Add(new Choice(mm->T("Game Settings", "Settings")))->OnClick.Handle(this, &MainScreen::OnGameSettings);
146 rightColumnItems->Add(new Choice(mm->T("Credits")))->OnClick.Handle(this, &MainScreen::OnCredits);
147 rightColumnItems->Add(new Choice(mm->T("www.ppsspp.org")))->OnClick.Handle(this, &MainScreen::OnPPSSPPOrg);
148 - if (!System_GetPropertyBool(SYSPROP_APP_GOLD)) {
149 - Choice *gold = rightColumnItems->Add(new Choice(mm->T("Buy PPSSPP Gold")));
150 - gold->OnClick.Handle(this, &MainScreen::OnSupport);
151 - gold->SetIcon(ImageID("I_ICONGOLD"));
152 - }
153
154 #if !PPSSPP_PLATFORM(UWP)
155 // Having an exit button is against UWP guidelines.
156 @@ -1118,32 +1109,6 @@ void MainScreen::CreateViews() {
157 } else if (tabHolder_->GetVisibility() != V_GONE) {
158 root_->SetDefaultFocusView(tabHolder_);
159 }
160 -
161 - auto u = GetI18NCategory("Upgrade");
162 -
163 - upgradeBar_ = 0;
164 - if (!g_Config.upgradeMessage.empty()) {
165 - upgradeBar_ = new LinearLayout(ORIENT_HORIZONTAL, new LinearLayoutParams(FILL_PARENT, WRAP_CONTENT));
166 -
167 - UI::Margins textMargins(10, 5);
168 - UI::Margins buttonMargins(0, 0);
169 - UI::Drawable solid(0xFFbd9939);
170 - upgradeBar_->SetBG(solid);
171 - upgradeBar_->Add(new TextView(u->T("New version of PPSSPP available") + std::string(": ") + g_Config.upgradeVersion, new LinearLayoutParams(1.0f, textMargins)));
172 -#if PPSSPP_PLATFORM(ANDROID) || PPSSPP_PLATFORM(WINDOWS)
173 - upgradeBar_->Add(new Button(u->T("Download"), new LinearLayoutParams(buttonMargins)))->OnClick.Handle(this, &MainScreen::OnDownloadUpgrade);
174 -#else
175 - upgradeBar_->Add(new Button(u->T("Details"), new LinearLayoutParams(buttonMargins)))->OnClick.Handle(this, &MainScreen::OnDownloadUpgrade);
176 -#endif
177 - upgradeBar_->Add(new Button(u->T("Dismiss"), new LinearLayoutParams(buttonMargins)))->OnClick.Handle(this, &MainScreen::OnDismissUpgrade);
178 -
179 - // Slip in under root_
180 - LinearLayout *newRoot = new LinearLayout(ORIENT_VERTICAL);
181 - newRoot->Add(root_);
182 - newRoot->Add(upgradeBar_);
183 - root_->ReplaceLayoutParams(new LinearLayoutParams(1.0));
184 - root_ = newRoot;
185 - }
186 }
187
188 UI::EventReturn MainScreen::OnAllowStorage(UI::EventParams &e) {
189 @@ -1151,30 +1116,6 @@ UI::EventReturn MainScreen::OnAllowStorage(UI::EventParams &e) {
190 return UI::EVENT_DONE;
191 }
192
193 -UI::EventReturn MainScreen::OnDownloadUpgrade(UI::EventParams &e) {
194 -#if PPSSPP_PLATFORM(ANDROID)
195 - // Go to app store
196 - if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
197 - LaunchBrowser("market://details?id=org.ppsspp.ppssppgold");
198 - } else {
199 - LaunchBrowser("market://details?id=org.ppsspp.ppsspp");
200 - }
201 -#elif PPSSPP_PLATFORM(WINDOWS)
202 - LaunchBrowser("https://www.ppsspp.org/downloads.html");
203 -#else
204 - // Go directly to ppsspp.org and let the user sort it out
205 - // (for details and in case downloads doesn't have their platform.)
206 - LaunchBrowser("https://www.ppsspp.org/");
207 -#endif
208 - return UI::EVENT_DONE;
209 -}
210 -
211 -UI::EventReturn MainScreen::OnDismissUpgrade(UI::EventParams &e) {
212 - g_Config.DismissUpgrade();
213 - upgradeBar_->SetVisibility(UI::V_GONE);
214 - return UI::EVENT_DONE;
215 -}
216 -
217 void MainScreen::sendMessage(const char *message, const char *value) {
218 // Always call the base class method first to handle the most common messages.
219 UIScreenWithBackground::sendMessage(message, value);
220 @@ -1390,15 +1331,6 @@ UI::EventReturn MainScreen::OnCredits(UI::EventParams &e) {
221 return UI::EVENT_DONE;
222 }
223
224 -UI::EventReturn MainScreen::OnSupport(UI::EventParams &e) {
225 -#ifdef __ANDROID__
226 - LaunchBrowser("market://details?id=org.ppsspp.ppssppgold");
227 -#else
228 - LaunchBrowser("https://central.ppsspp.org/buygold");
229 -#endif
230 - return UI::EVENT_DONE;
231 -}
232 -
233 UI::EventReturn MainScreen::OnPPSSPPOrg(UI::EventParams &e) {
234 LaunchBrowser("https://www.ppsspp.org");
235 return UI::EVENT_DONE;
236 diff --git a/UI/MiscScreens.cpp b/UI/MiscScreens.cpp
237 index a7284654b..2413d6c89 100644
238 --- a/UI/MiscScreens.cpp
239 +++ b/UI/MiscScreens.cpp
240 @@ -539,11 +539,7 @@ void LogoScreen::render() {
241 char temp[256];
242 // Manually formatting UTF-8 is fun. \xXX doesn't work everywhere.
243 snprintf(temp, sizeof(temp), "%s Henrik Rydg%c%crd", cr->T("created", "Created by"), 0xC3, 0xA5);
244 - if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
245 - dc.Draw()->DrawImage(ImageID("I_ICONGOLD"), bounds.centerX() - 120, bounds.centerY() - 30, 1.2f, textColor, ALIGN_CENTER);
246 - } else {
247 - dc.Draw()->DrawImage(ImageID("I_ICON"), bounds.centerX() - 120, bounds.centerY() - 30, 1.2f, textColor, ALIGN_CENTER);
248 - }
249 + dc.Draw()->DrawImage(ImageID("I_ICON"), bounds.centerX() - 120, bounds.centerY() - 30, 1.2f, textColor, ALIGN_CENTER);
250 dc.Draw()->DrawImage(ImageID("I_LOGO"), bounds.centerX() + 40, bounds.centerY() - 30, 1.5f, textColor, ALIGN_CENTER);
251 //dc.Draw()->DrawTextShadow(UBUNTU48, "PPSSPP", xres / 2, yres / 2 - 30, textColor, ALIGN_CENTER);
252 dc.SetFontScale(1.0f, 1.0f);
253 @@ -579,10 +575,6 @@ void CreditsScreen::CreateViews() {
254 // Really need to redo this whole layout with some linear layouts...
255
256 int rightYOffset = 0;
257 - if (!System_GetPropertyBool(SYSPROP_APP_GOLD)) {
258 - root_->Add(new Button(cr->T("Buy Gold"), new AnchorLayoutParams(260, 64, NONE, NONE, 10, 84, false)))->OnClick.Handle(this, &CreditsScreen::OnSupport);
259 - rightYOffset = 74;
260 - }
261 root_->Add(new Button(cr->T("PPSSPP Forums"), new AnchorLayoutParams(260, 64, 10, NONE, NONE, 158, false)))->OnClick.Handle(this, &CreditsScreen::OnForums);
262 root_->Add(new Button(cr->T("Discord"), new AnchorLayoutParams(260, 64, 10, NONE, NONE, 232, false)))->OnClick.Handle(this, &CreditsScreen::OnDiscord);
263 root_->Add(new Button("www.ppsspp.org", new AnchorLayoutParams(260, 64, 10, NONE, NONE, 10, false)))->OnClick.Handle(this, &CreditsScreen::OnPPSSPPOrg);
264 @@ -591,20 +583,7 @@ void CreditsScreen::CreateViews() {
265 #if PPSSPP_PLATFORM(ANDROID) || PPSSPP_PLATFORM(IOS)
266 root_->Add(new Button(cr->T("Share PPSSPP"), new AnchorLayoutParams(260, 64, NONE, NONE, 10, rightYOffset + 158, false)))->OnClick.Handle(this, &CreditsScreen::OnShare);
267 #endif
268 - if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
269 - root_->Add(new ImageView(ImageID("I_ICONGOLD"), IS_DEFAULT, new AnchorLayoutParams(100, 64, 10, 10, NONE, NONE, false)));
270 - } else {
271 - root_->Add(new ImageView(ImageID("I_ICON"), IS_DEFAULT, new AnchorLayoutParams(100, 64, 10, 10, NONE, NONE, false)));
272 - }
273 -}
274 -
275 -UI::EventReturn CreditsScreen::OnSupport(UI::EventParams &e) {
276 -#ifdef __ANDROID__
277 - LaunchBrowser("market://details?id=org.ppsspp.ppssppgold");
278 -#else
279 - LaunchBrowser("https://central.ppsspp.org/buygold");
280 -#endif
281 - return UI::EVENT_DONE;
282 + root_->Add(new ImageView(ImageID("I_ICON"), IS_DEFAULT, new AnchorLayoutParams(100, 64, 10, 10, NONE, NONE, false)));
283 }
284
285 UI::EventReturn CreditsScreen::OnTwitter(UI::EventParams &e) {
286 @@ -794,11 +773,7 @@ void CreditsScreen::render() {
287
288 // TODO: This is kinda ugly, done on every frame...
289 char temp[256];
290 - if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
291 - snprintf(temp, sizeof(temp), "PPSSPP Gold %s", PPSSPP_GIT_VERSION);
292 - } else {
293 - snprintf(temp, sizeof(temp), "PPSSPP %s", PPSSPP_GIT_VERSION);
294 - }
295 + snprintf(temp, sizeof(temp), "PPSSPP %s", PPSSPP_GIT_VERSION);
296 credits[0] = (const char *)temp;
297
298 UIContext &dc = *screenManager()->getUIContext();
299 diff --git a/UWP/PPSSPP_UWPMain.cpp b/UWP/PPSSPP_UWPMain.cpp
300 index 0ba7fac4b..d1b687c47 100644
301 --- a/UWP/PPSSPP_UWPMain.cpp
302 +++ b/UWP/PPSSPP_UWPMain.cpp
303 @@ -433,12 +433,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
304 return false;
305 case SYSPROP_HAS_BACK_BUTTON:
306 return true;
307 - case SYSPROP_APP_GOLD:
308 -#ifdef GOLD
309 - return true;
310 -#else
311 - return false;
312 -#endif
313 default:
314 return false;
315 }
316 diff --git a/Windows/MainWindowMenu.cpp b/Windows/MainWindowMenu.cpp
317 index 979a60ecb..a57927544 100644
318 --- a/Windows/MainWindowMenu.cpp
319 +++ b/Windows/MainWindowMenu.cpp
320 @@ -1393,7 +1393,7 @@ namespace MainWindow {
321 {
322 W32Util::CenterWindow(hDlg);
323 HWND versionBox = GetDlgItem(hDlg, IDC_VERSION);
324 - std::string windowText = System_GetPropertyBool(SYSPROP_APP_GOLD) ? "PPSSPP Gold " : "PPSSPP ";
325 + std::string windowText = "PPSSPP ";
326 windowText.append(PPSSPP_GIT_VERSION);
327 SetWindowText(versionBox, ConvertUTF8ToWString(windowText).c_str());
328 }
329 diff --git a/Windows/main.cpp b/Windows/main.cpp
330 index 4d948cfe5..e609cc1e0 100644
331 --- a/Windows/main.cpp
332 +++ b/Windows/main.cpp
333 @@ -301,12 +301,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
334 return true;
335 case SYSPROP_HAS_BACK_BUTTON:
336 return true;
337 - case SYSPROP_APP_GOLD:
338 -#ifdef GOLD
339 - return true;
340 -#else
341 - return false;
342 -#endif
343 default:
344 return false;
345 }
346 diff --git a/android/jni/app-android.cpp b/android/jni/app-android.cpp
347 index 10fdf97e5..736b1fa66 100644
348 --- a/android/jni/app-android.cpp
349 +++ b/android/jni/app-android.cpp
350 @@ -437,12 +437,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
351 case SYSPROP_HAS_FOLDER_BROWSER:
352 // Uses OPEN_DOCUMENT_TREE to let you select a folder.
353 return androidVersion >= 21;
354 - case SYSPROP_APP_GOLD:
355 -#ifdef GOLD
356 - return true;
357 -#else
358 - return false;
359 -#endif
360 default:
361 return false;
362 }
363 --
364 2.30.1
365