gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / perl-www-curl-fix-struct-void.patch
1 From: Tobias Geerinckx-Rice <me@tobias.gr>
2 Date: Sat, 14 Nov 2020 15:40:56 +0100
3 Subject: [PATCH] gnu: perl-www-curl: Fix struct void* usage.
4
5 Copied verbatim from Gentoo[0]. Fixes:
6
7 Curl.xs:76:12: error: expected ‘{’ before ‘void’
8 struct void *curlm;
9 ^~~~
10 Curl.xs:76:12: error: two or more data types in declaration specifiers
11
12 [0]: https://694466.bugs.gentoo.org/attachment.cgi?id=595098
13
14 --- WWW-Curl-4.17/Curl.xs 2014-02-21 18:08:30.000000000 +0200
15 +++ WWW-Curl-4.17.new/Curl.xs 2019-11-05 21:44:55.434395739 +0200
16 @@ -73,7 +73,7 @@ typedef struct {
17 #ifdef __CURL_MULTI_H
18 struct CURLM *curlm;
19 #else
20 - struct void *curlm;
21 + void *curlm;
22 #endif
23 } perl_curl_multi;
24