gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / owncloud-disable-updatecheck.patch
1 This patch is taken from Debian and modified slightly
2
3 Description: Phoning-home version checks should be disabled in Debian packages
4 Author: Sandro Knauß <bugs@ssandroknauss.de>
5 Origin: debian
6 Bug-debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721341
7 Forwarded: not-needed
8 Last-Update: 2014-02-17
9 ---
10 This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
11 --- a/src/libsync/configfile.cpp
12 +++ b/src/libsync/configfile.cpp
13 @@ -522,11 +522,14 @@ bool ConfigFile::skipUpdateCheck(const Q
14 if (connection.isEmpty())
15 con = defaultConnection();
16
17 - QVariant fallback = getValue(skipUpdateCheckC(), con, false);
18 + QVariant fallback = getValue(skipUpdateCheckC(), con, true);
19 fallback = getValue(skipUpdateCheckC(), QString(), fallback);
20
21 QVariant value = getPolicySetting(skipUpdateCheckC(), fallback);
22 - return value.toBool();
23 + if ( !value.toBool() )
24 + qDebug() << "Guix has disabled the UpdateCheck mechanism.";
25 +
26 + return true;
27 }
28
29 void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection)
30 --- a/src/gui/generalsettings.cpp
31 +++ b/src/gui/generalsettings.cpp
32 @@ -146,6 +149,7 @@ void GeneralSettings::loadMiscSettings()
33
34 void GeneralSettings::slotUpdateInfo()
35 {
36 + /* Guix doesn't want an autoupdater
37 if (ConfigFile().skipUpdateCheck() || !Updater::instance()) {
38 // updater disabled on compile
39 _ui->updaterWidget->setVisible(false);
40 @@ -174,6 +178,9 @@ void GeneralSettings::slotUpdateInfo()
41 _ui->updateChannel->setCurrentIndex(ConfigFile().updateChannel() == "beta" ? 1 : 0);
42 connect(_ui->updateChannel, static_cast<void (QComboBox::*)(int)>(&QComboBox::currentIndexChanged),
43 this, &GeneralSettings::slotUpdateChannelChanged, Qt::UniqueConnection);
44 + */
45 + //hide the update group box for Guix.
46 + _ui->updaterWidget->setVisible(false);
47 }
48
49 void GeneralSettings::slotUpdateChannelChanged(int index)