gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / opencv-fix-build-of-grfmt_jpeg2000.cpp.patch
1 From: Tobias Geerinckx-Rice <me@tobias.gr>
2 Date: Thu, 13 Aug 2020 15:21:30 +0200
3 Subject: [PATCH] gnu: opencv: Fix build with Jasper 2.0.19.
4
5 Taken verbatim from upstream: <https://github.com/opencv/opencv/issues/17984>.
6
7 From f66fc199a20882c546fa31142e9c0f5a8b3cf983 Mon Sep 17 00:00:00 2001
8 From: Florian Jung <flo@windfis.ch>
9 Date: Wed, 29 Jul 2020 18:51:55 +0200
10 Subject: [PATCH] Fix build of grfmt_jpeg2000.cpp
11
12 libjasper has recently changed `jas_matrix_get` from a macro to an inline function
13 (389951d071 in https://github.com/jasper-software/jasper), causing the build to fail.
14 ---
15 modules/imgcodecs/src/grfmt_jpeg2000.cpp | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18 diff --git a/modules/imgcodecs/src/grfmt_jpeg2000.cpp b/modules/imgcodecs/src/grfmt_jpeg2000.cpp
19 index fe69f80c86f..0f4d28d6f4d 100644
20 --- a/modules/imgcodecs/src/grfmt_jpeg2000.cpp
21 +++ b/modules/imgcodecs/src/grfmt_jpeg2000.cpp
22 @@ -377,7 +377,7 @@ bool Jpeg2KDecoder::readComponent8u( uchar *data, void *_buffer,
23
24 for( y = 0; y < yend - ystart; )
25 {
26 - jas_seqent_t* pix_row = &jas_matrix_get( buffer, y / ystep, 0 );
27 + jas_seqent_t* pix_row = jas_matrix_getref( buffer, y / ystep, 0 );
28 uchar* dst = data + (y - yoffset) * step - xoffset;
29
30 if( xstep == 1 )
31 @@ -443,7 +443,7 @@ bool Jpeg2KDecoder::readComponent16u( unsigned short *data, void *_buffer,
32
33 for( y = 0; y < yend - ystart; )
34 {
35 - jas_seqent_t* pix_row = &jas_matrix_get( buffer, y / ystep, 0 );
36 + jas_seqent_t* pix_row = jas_matrix_getref( buffer, y / ystep, 0 );
37 ushort* dst = data + (y - yoffset) * step - xoffset;
38
39 if( xstep == 1 )