gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ocaml-dose3-Install-mli-cmx-etc.patch
1 From b5314c20d8e3caf62fe0dc96ad937a2950158b23 Mon Sep 17 00:00:00 2001
2 From: Louis Gesbert <louis.gesbert@ocamlpro.com>
3 Date: Thu, 2 Mar 2017 12:19:56 +0100
4 Subject: [PATCH] Install mli, cmx, etc.
5
6 ---
7 Makefile | 26 +++++++++++++-------------
8 1 file changed, 13 insertions(+), 13 deletions(-)
9
10 diff --git a/Makefile b/Makefile
11 index 09464ff..5044d7f 100644
12 --- a/Makefile
13 +++ b/Makefile
14 @@ -56,7 +56,7 @@ $(DOSELIBS)/cudf.%:
15 @for i in _build/cudf/cudf.*; do \
16 if [ -e $$i ]; then \
17 cp $$i $(DOSELIBS) ; \
18 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
19 + rm -f $(DOSELIBS)/*.mlpack ; \
20 fi ; \
21 done
22
23 @@ -67,7 +67,7 @@ $(DOSELIBS)/common.%: common/*.ml common/*.mli
24 if [ -e $$i ]; then \
25 cp $$i $(DOSELIBS) ; \
26 rm $$i ;\
27 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
28 + rm -f $(DOSELIBS)/*.mlpack ; \
29 fi ; \
30 done
31
32 @@ -78,7 +78,7 @@ $(DOSELIBS)/versioning.%: versioning/*.ml versioning/*.mli
33 if [ -e $$i ]; then \
34 cp $$i $(DOSELIBS) ; \
35 rm $$i ;\
36 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
37 + rm -f $(DOSELIBS)/*.mlpack ; \
38 fi ; \
39 done
40
41 @@ -88,7 +88,7 @@ $(DOSELIBS)/algo.%: algo/*.ml algo/*.mli $(DOSELIBS)/common.%
42 if [ -e $$i ]; then \
43 cp $$i $(DOSELIBS) ; \
44 rm $$i ;\
45 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
46 + rm -f $(DOSELIBS)/*.mlpack ; \
47 fi ; \
48 done
49
50 @@ -98,7 +98,7 @@ $(DOSELIBS)/debian.%: deb/*.ml deb/*.mli $(DOSELIBS)/pef.%
51 if [ -e $$i ]; then \
52 cp $$i $(DOSELIBS) ; \
53 rm $$i ;\
54 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
55 + rm -f $(DOSELIBS)/*.mlpack ; \
56 fi ; \
57 done
58
59 @@ -108,7 +108,7 @@ $(DOSELIBS)/opam.%: opam/*.ml opam/*.mli $(DOSELIBS)/pef.%
60 if [ -e $$i ]; then \
61 cp $$i $(DOSELIBS) ; \
62 rm $$i ;\
63 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
64 + rm -f $(DOSELIBS)/*.mlpack ; \
65 fi ; \
66 done
67
68 @@ -118,7 +118,7 @@ $(DOSELIBS)/npm.%: npm/*.ml npm/*.mli $(DOSELIBS)/versioning.% $(DOSELIBS)/pef.%
69 if [ -e $$i ]; then \
70 cp $$i $(DOSELIBS) ; \
71 rm $$i ;\
72 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
73 + rm -f $(DOSELIBS)/*.mlpack ; \
74 fi ; \
75 done
76
77 @@ -128,7 +128,7 @@ $(DOSELIBS)/rpm.%: rpm/*.ml $(DOSELIBS)/algo.%
78 if [ -e $$i ]; then \
79 cp $$i $(DOSELIBS) ; \
80 rm $$i ;\
81 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
82 + rm -f $(DOSELIBS)/*.mlpack ; \
83 fi ; \
84 done
85
86 @@ -138,7 +138,7 @@ $(DOSELIBS)/pef.%: pef/*.ml pef/*.mli
87 if [ -e $$i ]; then \
88 cp $$i $(DOSELIBS) ; \
89 rm $$i ;\
90 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
91 + rm -f $(DOSELIBS)/*.mlpack ; \
92 fi ; \
93 done
94
95 @@ -148,7 +148,7 @@ $(DOSELIBS)/csw.%: opencsw/*.ml $(DOSELIBS)/versioning.%
96 if [ -e $$i ]; then \
97 cp $$i $(DOSELIBS) ; \
98 rm $$i ;\
99 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ; \
100 + rm -f $(DOSELIBS)/*.mlpack ; \
101 fi ; \
102 done
103
104 @@ -158,7 +158,7 @@ $(DOSELIBS)/doseparse.%: $(DOSELIBS)/pef.% $(DOSELIBS)/debian.%
105 if [ -e $$i ]; then \
106 cp $$i $(DOSELIBS) ; \
107 rm $$i ;\
108 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx $(DOSELIBS)/*.ml ; \
109 + rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.ml ; \
110 fi ; \
111 done
112
113 @@ -168,7 +168,7 @@ $(DOSELIBS)/doseparseNoRpm.%: $(DOSELIBS)/pef.% $(DOSELIBS)/debian.%
114 if [ -e $$i ]; then \
115 cp $$i $(DOSELIBS) ;\
116 rm $$i ;\
117 - rm -f $(DOSELIBS)/*.mlpack $(DOSELIBS)/*.cmx ;\
118 + rm -f $(DOSELIBS)/*.mlpack ;\
119 fi ; \
120 done
121
122 @@ -223,7 +223,7 @@ INSTALL_STUFF_ = META
123 INSTALL_STUFF_ += $(wildcard _build/doselibs/*.cma _build/doselibs/*.cmi)
124 INSTALL_STUFF_ += $(wildcard _build/doselibs/*.cmxa _build/doselibs/*.cmxs)
125 INSTALL_STUFF_ += $(wildcard _build/doselibs/*.a)
126 -#INSTALL_STUFF_ += $(wildcard _build/*/*.mli)
127 +INSTALL_STUFF_ += $(wildcard _build/doselibs/*.mli) $(wildcard _build/doselibs/*.cmti) $(wildcard _build/doselibs/*.cmx)
128 INSTALL_STUFF_ += $(wildcard _build/rpm/*.so)
129
130 exclude_cudf = $(wildcard _build/doselibs/*cudf* _build/cudf/*)
131 --
132 2.11.0
133