gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ncompress-fix-softlinks.patch
1 Patch taken from Debian sid. Adapted to 4.2.4.6 for Guix by Tobias
2 Geerinckx-Rice <me@tobias.gr>.
3
4 Description: Support uncompressing and compressing soft links.
5 Historically, ncompress for Debian has been built using a command line
6 directly in debian/rules. For 4.2.4.5-1, I simplified by swtching to the
7 upstream Makefile. However, that caused a regression - the Debian version of
8 ncompress has always successfully handled soft links, but this stopped
9 working. To revert to the original behavior, I need to remove -DLSTAT from
10 the build options, to be consistent with how the code was previously built.
11 Author: Kenneth J. Pronovici <pronovic@debian.org>
12 Bug-Debian: http://bugs.debian.org/918836
13 Index: ncompress/GNUmakefile
14 ===================================================================
15 --- ncompress.orig/GNUmakefile
16 +++ ncompress/GNUmakefile
17 @@ -9,7 +9,7 @@ distclean: cleanup
18
19 Makefile: Makefile.def GNUmakefile
20 sed \
21 - -e 's:options= :options= -DUTIME_H -DLSTAT :' \
22 + -e 's:options= :options= -DUTIME_H :' \
23 Makefile.def > Makefile
24
25 check: