gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / mupen64plus-ui-console-notice.patch
1 Mupen64Plus supports a single data directory and a single plugin directory in
2 its configuration, yet we need data and plugin files from a variety of
3 packages. The best way to deal with this is to install all packages from
4 which data and plugin files are needed into one's profile, and point the
5 configuration there. Hence, the ui-console package provides propagated inputs
6 for packages with the most important data and plugin files, and this patch
7 provides the user instructions on what needs to be done in order to have
8 Mupen64Plus find the relevant data and plugins.
9
10 --- a/src/plugin.c
11 +++ b/src/plugin.c
12 @@ -122,6 +122,22 @@ m64p_error PluginSearchLoad(m64p_handle ConfigUI)
13 {
14 const char *plugindir = (*ConfigGetParamString)(ConfigUI, "PluginDir");
15 lib_filelist = osal_library_search(plugindir);
16 + /* Guix specific */
17 + if (lib_filelist == NULL)
18 + {
19 + DebugMessage(M64MSG_ERROR, "No plugins found in PluginDir path: %s", plugindir);
20 + DebugMessage(M64MSG_ERROR,
21 + "\n\n"
22 + "*********************************\n"
23 + "*** Notice for GNU Guix users ***\n"
24 + "*********************************\n"
25 + "\n"
26 + "You might want to edit your mupen64plus.cfg (in $XDG_CONFIG_HOME by default)\n"
27 + "and set SharedDataPath to /path/to/my_guix_profile/share/mupen64plus and\n"
28 + "PluginDir to /path/to/my_guix_profile/lib/mupen64plus so that data and plugins\n"
29 + "are found.\n"
30 + "\n");
31 + }
32 }
33
34 /* if still no plugins found, search some common system folders */