gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / minisat-install.patch
1 Avoid the default dynamic executable, which depends on minisat.so
2 Instead install the release version, which is statically linked.
3
4 diff --git a/Makefile b/Makefile
5 index ceb9d77..7b91906 100644
6 --- a/Makefile
7 +++ b/Makefile
8 @@ -191,9 +191,9 @@ install-lib: $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(BUILD_DIR)/dynamic/lib/$
9 ln -sf $(MINISAT_DLIB).$(SOMAJOR) $(DESTDIR)$(libdir)/$(MINISAT_DLIB)
10 $(INSTALL) -m 644 $(BUILD_DIR)/release/lib/$(MINISAT_SLIB) $(DESTDIR)$(libdir)
11
12 -install-bin: $(BUILD_DIR)/dynamic/bin/$(MINISAT)
13 +install-bin: $(BUILD_DIR)/release/bin/$(MINISAT)
14 $(INSTALL) -d $(DESTDIR)$(bindir)
15 - $(INSTALL) -m 755 $(BUILD_DIR)/dynamic/bin/$(MINISAT) $(DESTDIR)$(bindir)
16 + $(INSTALL) -m 755 $(BUILD_DIR)/release/bin/$(MINISAT) $(DESTDIR)$(bindir)
17
18 clean:
19 rm -f $(foreach t, release debug profile dynamic, $(foreach o, $(SRCS:.cc=.o), $(BUILD_DIR)/$t/$o)) \