gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / lsh-fix-x11-forwarding.patch
1 --- a/src/server_x11.c 2016-08-01 11:58:54.714647794 +0200
2 +++ b/src/server_x11.c 2016-08-01 11:58:46.606563478 +0200
3 @@ -151,7 +151,7 @@ DEFINE_COMMAND(open_forwarded_x11)
4 #define X11_MIN_DISPLAY 10
5 #define X11_MAX_DISPLAY 1000
6
7 -/* FIXME: Create the /tmp/.X11-unix directory, if needed. Figure out
8 +/* FIXME: Figure out
9 * if and how we should use /tmp/.X17-lock. Consider using display
10 * "unix:17" instead of just ":17".
11 */
12 @@ -253,6 +253,7 @@ open_x11_socket(struct ssh_channel *chan
13
14 old_umask = umask(0077);
15
16 + mkdir(X11_SOCKET_DIR, S_IRWXU | S_IRWXG | S_IRWXO | S_ISVTX);
17 old_cd = lsh_pushd(X11_SOCKET_DIR, &dir, 0, 0);
18 if (old_cd < 0)
19 {
20