gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / libgnomeui-utf8.patch
1 Fixes build with Python >= 3.6:
2
3 ------
4 Making all in libgnomeui
5 make[2]: Entering directory '/tmp/guix-build-libgnomeui-2.24.5.drv-0/libgnomeui-2.24.5/libgnomeui'
6 GEN stamp-gnome-marshal.h
7 GEN stamp-gnometypebuiltins.h
8 INFO: Reading ./gnome-marshal.list...
9 GEN gnome-marshal.h
10 Traceback (most recent call last):
11 File "/gnu/store/...-glib-2.54.2-bin/bin/glib-mkenums", line 688, in <module>
12 process_file(fname)
13 File "/gnu/store/...-glib-2.54.2-bin/bin/glib-mkenums", line 420, in process_file
14 line = curfile.readline()
15 File "/gnu/store/...-python-3.6.3/lib/python3.6/codecs.py", line 321, in decode
16 (result, consumed) = self._buffer_decode(data, self.errors, final)
17 UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf1 in position 1009: invalid continuation byte
18 make[2]: *** [Makefile:1109: stamp-gnometypebuiltins.h] Error 1
19 make[2]: Leaving directory '/tmp/guix-build-libgnomeui-2.24.5.drv-0/libgnomeui-2.24.5/libgnomeui'
20 make[1]: *** [Makefile:369: all-recursive] Error 1
21 make[1]: Leaving directory '/tmp/guix-build-libgnomeui-2.24.5.drv-0/libgnomeui-2.24.5'
22 make: *** [Makefile:296: all] Error 2
23 ------
24
25 Patch copied from upstream source repository:
26
27 https://git.gnome.org/browse/libgnomeui/commit/?id=30334c28794ef85d8973f4ed0779b5ceed6594f2
28
29 From 30334c28794ef85d8973f4ed0779b5ceed6594f2 Mon Sep 17 00:00:00 2001
30 From: Colin Walters <walters@verbum.org>
31 Date: Mon, 7 Aug 2017 13:15:26 -0400
32 Subject: [PATCH] gnome-scores.h: Convert to UTF-8
33
34 The new Python `glib-mkenums` barfs on ISO-8859-1 input.
35 ---
36 libgnomeui/gnome-scores.h | 2 +-
37 1 file changed, 1 insertion(+), 1 deletion(-)
38
39 diff --git a/libgnomeui/gnome-scores.h b/libgnomeui/gnome-scores.h
40 index 911b12d1..4e641d22 100644
41 --- a/libgnomeui/gnome-scores.h
42 +++ b/libgnomeui/gnome-scores.h
43 @@ -27,7 +27,7 @@
44 * "High Scores" Widget
45 *
46 * AUTHOR:
47 - * Horacio J. Peña <horape@compendium.com.ar>
48 + * Horacio J. Peña <horape@compendium.com.ar>
49 *
50 * This is free software (under the terms of the GNU LGPL)
51 *