gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / libgnome-encoding.patch
1 Remove non-UTF-8 character (this is a NO-BREAK SPACE character, encoded in
2 ISO-8859-1) to fix build failure with 'glib-mkenums' in GLib 2.54.2+.
3
4 Patch from <https://github.com/macports/macports-ports/commit/1f3efc8e65cc060d1701407bd1e56e62e6bd9c55>.
5
6 --- a/libgnome/gnome-config.h 2009-04-23 04:29:13.000000000 -0500
7 +++ b/libgnome/gnome-config.h 2017-10-04 02:17:22.000000000 -0500
8 @@ -270,7 +270,7 @@ void gnome_config_clean_key_ (const char
9 #define gnome_config_private_clean_key(path) \
10 (gnome_config_clean_key_((path),TRUE))
11
12 -/* returns the true filename of the config fileĀ */
13 +/* returns the true filename of the config file */
14 #define gnome_config_get_real_path(path) \
15 (g_build_filename (gnome_user_dir_get(),(path),NULL))
16 #define gnome_config_private_get_real_path(path) \