gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ldc-disable-phobos-tests.patch
1 diff --git a/std/socket.d b/std/socket.d
2 index 111cd17..6d23da9 100644
3 --- a/std/socket.d
4 +++ b/std/socket.d
5 @@ -448,7 +448,7 @@ class Protocol
6 // Skip this test on Android because getprotobyname/number are
7 // unimplemented in bionic.
8 version(CRuntime_Bionic) {} else
9 -@safe unittest
10 +@safe version(hasNetwork) unittest
11 {
12 // import std.stdio : writefln;
13 softUnittest({
14 @@ -770,7 +770,7 @@ class InternetHost
15 }
16
17 ///
18 -@safe unittest
19 +@safe version(hasNetwork) unittest
20 {
21 InternetHost ih = new InternetHost;
22