gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / lcalc-default-parameters-2.patch
1 Patch taken from the Sage packaging system.
2
3 --- lcalc-1.23/include/Lgamma.h 2012-08-08 23:21:55.000000000 +0200
4 +++ lcalc-1.23/include/Lgamma.h 2014-05-18 21:15:27.786889718 +0200
5 @@ -77,7 +77,7 @@
6 //n=0 should just give log_GAMMA(z)... thus making log_GAMMA
7 //code obsolete. But leave log_GAMMA intact anyways.
8 template <class ttype>
9 -precise(ttype) log_GAMMA (ttype z,int n=0)
10 +precise(ttype) log_GAMMA (ttype z,int n)
11 {
12 int M;
13 precise(ttype) log_G,r,r2,y;
14 @@ -230,7 +230,7 @@
15 //value exp_w which holds exp(-w)
16 //computes G(z,w), so there's an extra w^(-z) factor.
17 template <class ttype>
18 -Complex inc_GAMMA (ttype z,ttype w, const char *method="temme", ttype exp_w = 0, bool recycle=false)
19 +Complex inc_GAMMA (ttype z,ttype w, const char *method, ttype exp_w, bool recycle)
20 {
21
22 Complex G;
23 @@ -334,7 +334,7 @@
24
25
26 template <class ttype>
27 -ttype cfrac_GAMMA (ttype z,ttype w, ttype exp_w=0, bool recycle=false) //computes G(z,w) via continued fraction
28 +ttype cfrac_GAMMA (ttype z,ttype w, ttype exp_w, bool recycle) //computes G(z,w) via continued fraction
29 {
30
31 ttype G;
32 @@ -424,7 +424,7 @@
33 }
34
35 template <class ttype>
36 -ttype asympt_GAMMA (ttype z,ttype w, ttype exp_w = 0, bool recycle=false) //computes G(z,w) via asymptotic series
37 +ttype asympt_GAMMA (ttype z,ttype w, ttype exp_w, bool recycle) //computes G(z,w) via asymptotic series
38 {
39
40 if(my_verbose>3) cout << "called asympt_GAMMA("<<z<<","<<w<<")"<< endl;
41 @@ -446,7 +446,7 @@
42
43
44 template <class ttype>
45 -ttype comp_inc_GAMMA (ttype z,ttype w,ttype exp_w = 0, bool recycle=false) //computes g(z,w)
46 +ttype comp_inc_GAMMA (ttype z,ttype w,ttype exp_w, bool recycle) //computes g(z,w)
47 {
48
49 ttype g;
50 @@ -604,7 +604,7 @@
51 }
52
53 template <class ttype>
54 -Complex gamma_sum(Complex s, int what_type, ttype *coeff, int N, Double g, Complex l, Double Q, Long Period, Complex delta=1, const char *method="temme")
55 +Complex gamma_sum(Complex s, int what_type, ttype *coeff, int N, Double g, Complex l, Double Q, Long Period, Complex delta, const char *method)
56 {
57 Complex SUM=0;
58