gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / kobodeluxe-paths.patch
1 # Patch snarfed from
2 # http://http.debian.net/debian/pool/main/k/kobodeluxe/kobodeluxe_0.5.1-8.debian.tar.xz
3 #
4 # Disable reading of configs, graphics, and data from the current directory.
5 # So it's safe to run kobodeluxe from anywhere w/o worry about an attacker
6 # feeding it bad data.
7 --- kobodeluxe-0.5.1.orig/kobo.cpp
8 +++ kobodeluxe-0.5.1/kobo.cpp
9 @@ -141,21 +141,21 @@
10 * Graphics data
11 */
12 /* Current dir; from within the build tree */
13 - fmap->addpath("GFX", "./data/gfx");
14 + //fmap->addpath("GFX", "./data/gfx");
15 /* Real data dir */
16 fmap->addpath("GFX", "DATA>>gfx");
17 /* Current dir */
18 - fmap->addpath("GFX", "./gfx");
19 + //fmap->addpath("GFX", "./gfx");
20
21 /*
22 * Sound data
23 */
24 /* Current dir; from within the build tree */
25 - fmap->addpath("SFX", "./data/sfx");
26 + //fmap->addpath("SFX", "./data/sfx");
27 /* Real data dir */
28 fmap->addpath("SFX", "DATA>>sfx");
29 /* Current dir */
30 - fmap->addpath("SFX", "./sfx");
31 + //fmap->addpath("SFX", "./sfx");
32
33 /*
34 * Score files (user and global)
35 @@ -173,7 +173,7 @@
36 /* System local */
37 fmap->addpath("CONFIG", SYSCONF_DIR);
38 /* In current dir (last resort) */
39 - fmap->addpath("CONFIG", "./");
40 + //fmap->addpath("CONFIG", "./");
41 }
42
43