gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / kdbusaddons-kinit-file-name.patch
1 Add placeholder for kinit's store file name.
2
3 diff --git a/src/kdeinitinterface.cpp b/src/kdeinitinterface.cpp
4 index 22fa5e5..3d40937 100644
5 --- a/src/kdeinitinterface.cpp
6 +++ b/src/kdeinitinterface.cpp
7 @@ -52,7 +52,7 @@ void KDEInitInterface::ensureKdeinitRunning()
8 // If not found in system paths, search other paths
9 if (srv.isEmpty()) {
10 const QStringList searchPaths = QStringList()
11 - << QCoreApplication::applicationDirPath() // then look where our application binary is located
12 + << QString::fromUtf8("@SUBSTITUTEME@/bin") // using QStringLiteral would be more efficient, but breaks guix store reference detection.
13 << QLibraryInfo::location(QLibraryInfo::BinariesPath); // look where exec path is (can be set in qt.conf)
14 srv = QStandardPaths::findExecutable(QStringLiteral("kdeinit5"), searchPaths);
15 if (srv.isEmpty()) {