gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / java-xerces-build_dont_unzip.patch
1 Don't unzip the sources which were bundled originally. Guix strips them from
2 the source and uses pre-build packages.
3
4 Taken from https://anonscm.debian.org/viewvc/pkg-java/trunk/libxerces2-java/debian/patches/02_build_dont_unzip.patch?revision=14507
5
6 Index: b/build.xml
7 ===================================================================
8 --- a/build.xml
9 +++ b/build.xml
10 @@ -247,7 +247,7 @@
11 <copy file="${src.dir}/org/apache/xerces/impl/xpath/regex/message.properties"
12 tofile="${build.src}/org/apache/xerces/impl/xpath/regex/message_en.properties"/>
13
14 - <!-- now deal with API's: -->
15 + <!-- not needed for Debian
16 <unzip src="${src.apis.zip}" dest="${build.src}">
17 <patternset
18 includes="org/xml/sax/**
19 @@ -270,6 +270,7 @@
20 org/w3c/dom/xpath/**"
21 />
22 </unzip>
23 + -->
24
25 <!-- substitute tokens as needed -->
26 <replace file="${build.dir}/src/org/apache/xerces/impl/Version.java"
27 @@ -1232,7 +1233,7 @@
28 <replace file="${build.dir}/src/org/apache/xerces/parsers/AbstractSAXParser.java"
29 token="return (fConfiguration instanceof XML11Configurable);" value="return false;"/>
30
31 - <!-- now deal with API's: -->
32 + <!-- not needed for Debian
33 <unzip src="${src.apis.zip}" dest="${build.src}">
34 <patternset
35 includes="org/xml/sax/**
36 @@ -1255,7 +1256,7 @@
37 org/w3c/dom/xpath/**"
38 />
39 </unzip>
40 -
41 + -->
42
43 <!-- substitute tokens as needed -->
44 <replace file="${build.dir}/src/org/apache/xerces/impl/Version.java"