gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / java-simple-xml-fix-tests.patch
1 From b3b7a305f1278ec414500bf96c4c7a7f634c941b Mon Sep 17 00:00:00 2001
2 From: =?UTF-8?q?Jens=20Thee=C3=9F?= <theess@subshell.com>
3 Date: Thu, 15 Sep 2016 13:08:26 +0200
4 Subject: [PATCH] Dictionary uses stable order. This fixes unit tests.
5
6 This is upstream pull request #15:
7 https://github.com/ngallagher/simplexml/pull/15
8 This software is unmaintained, this pull request will no get merged.
9 The patch is modified, to match the directory layout of the tarball.
10
11 ---
12 src/main/java/org/simpleframework/xml/util/Dictionary.java | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15 diff --git a/src/main/java/org/simpleframework/xml/util/Dictionary.java b/src/main/java/org/simpleframework/xml/util/Dictionary.java
16 index 077d2514..c7327426 100644
17 --- a/src/org/simpleframework/xml/util/Dictionary.java
18 +++ b/src/org/simpleframework/xml/util/Dictionary.java
19 @@ -19,8 +19,8 @@
20 package org.simpleframework.xml.util;
21
22 import java.util.AbstractSet;
23 -import java.util.HashMap;
24 import java.util.Iterator;
25 +import java.util.LinkedHashMap;
26
27 /**
28 * The <code>Dictionary</code> object represents a mapped set of entry
29 @@ -134,7 +134,7 @@ public T remove(String name) {
30 *
31 * @see org.simpleframework.xml.util.Entry
32 */
33 - private static class Table<T> extends HashMap<String, T> {
34 + private static class Table<T> extends LinkedHashMap<String, T> {
35
36 /**
37 * Constructor for the <code>Table</code> object. This will