gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / jacal-fix-texinfo.patch
1 Fix the broken Texinfo in the Jacal package documentation
2
3 --- jacal/jacal.texi,orig 2017-02-23 20:35:55.303980444 +0100
4 +++ jacal/jacal.texi 2017-02-23 20:53:14.539024674 +0100
5 @@ -343,7 +343,7 @@
6
7 With the standard input grammar, the precedence of @samp{-} as a prefix
8 behaves strangely. @code{a^-b*c} becomes @code{a^(-b*c)} while
9 -@code{@result{a^b*c} (a^b)*c}.
10 +@code{a^b*c @result{} (a^b)*c}.
11
12 Using @code{divide} to divide a polynomial by an integer does not work.
13
14 @@ -675,8 +675,9 @@
15 e1: ---------
16 a
17 @end example
18 +@end deffn
19
20 -@deffnx Command suchthat var exp
21 +@deffn Command suchthat var exp
22
23 If an expression rather than an equation is given to @code{suchthat}, it
24 is as though the equation @code{@var{exp}=0} was given.
25 @@ -688,8 +689,9 @@
26 e2: ---------
27 a
28 @end example
29 +@end deffn
30
31 -@deffnx Operator | var exp_or_eqn
32 +@deffn Operator | var exp_or_eqn
33
34 An alternative infix notation is also available for @code{suchthat}.
35
36 @@ -857,8 +859,9 @@
37
38 Returns the degree of polynomial or equation @var{poly} in variable
39 @var{var}.
40 +@end deffn
41
42 -@deffnx Operator degree poly
43 +@deffn Operator degree poly
44
45 Returns the total-degree, the degree of its highest degree monomial,
46 of polynomial or equation @var{poly}.
47 @@ -1016,10 +1019,12 @@
48 Returns @var{poly1} reduced with respect to @var{poly2} (or @var{eqn})
49 and @var{var}. If @var{poly2} is univariate, the third argument is not
50 needed.
51 +@end deffn
52
53 -@deffnx Command mod poly1 n
54 +@deffn Command mod poly1 n
55 Returns @var{poly1} with all the coefficients taken modulo @var{n}.
56 -@deffnx Command mod poly1
57 +@end deffn
58 +@deffn Command mod poly1
59 Returns @var{poly1} with all the coefficients taken modulo the
60 current modulus.
61
62 @@ -1220,8 +1225,9 @@
63 e1: -1 2 3 5
64 @end group
65 @end example
66 +@end deffn
67
68 -@deffnx Command factor polyratio
69 +@deffn Command factor polyratio
70 Given a univariate ratio of polynomials @var{polyratio}, returns a
71 matrix of factors and exponents.
72
73 @@ -2028,7 +2034,7 @@
74 formed from the pair-wise products of components of the inputs. For
75 example, for the input tensors @code{x[a,b]} and @code{y[c]}
76 @example
77 -@result{z:tmult(x,y);} z[a,b,c] = x[a,b]*y[c]
78 +z:tmult(x,y); @result{} z[a,b,c] = x[a,b]*y[c]
79 @end example
80
81 With an additional argument, @code{tmult} will produce the inner product
82 @@ -2464,8 +2470,9 @@
83 If you do not wish to return to Jacal but really want to terminate the
84 session and return to the operating system, then after typing
85 @code{qed();}, type @code{(slib:exit)} or use @code{quit}.
86 +@end deffn
87
88 -@deffnx Command quit
89 +@deffn Command quit
90 Exit directly from Jacal to the operating system. You will not be able
91 to continue your Jacal session.
92