gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / imagemagick-ReadDCMImage-fix.patch
1 From 512668dfd92b20d0d08b91d62b422d8262573281 Mon Sep 17 00:00:00 2001
2 From: Dirk Lemstra <dirk@lemstra.org>
3 Date: Wed, 24 Mar 2021 20:37:15 +0100
4 Subject: [PATCH] Throw exception when no exception was raised but status was
5 false (#3432).
6
7 ---
8 coders/dcm.c | 2 ++
9 1 file changed, 2 insertions(+)
10
11 diff --git a/coders/dcm.c b/coders/dcm.c
12 index 7a68ed6e8..ed17c9567 100644
13 --- a/coders/dcm.c
14 +++ b/coders/dcm.c
15 @@ -3989,6 +3989,8 @@ static Image *ReadDCMImage(const ImageInfo *image_info,ExceptionInfo *exception)
16 if (redmap != (int *) NULL)
17 redmap=(int *) RelinquishMagickMemory(redmap);
18 image=DestroyImageList(image);
19 + if ((status == MagickFalse) && (exception->severity < ErrorException))
20 + ThrowReaderException(CorruptImageError,"CorruptImage");
21 return(GetFirstImageInList(images));
22 }
23 if (info.depth != (1UL*MAGICKCORE_QUANTUM_DEPTH))
24 --
25 2.31.0
26