gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / hubbub-sort-entities.patch
1 Traverse the entities hash's keys in sorted order to ensure reproducibility.
2
3 --- libhubbub-0.3.3/build/make-entities.pl
4 +++ libhubbub-0.3.3/build/make-entities.pl
5 @@ -86,7 +86,7 @@
6
7 my $trie;
8
9 -foreach my $key (keys %entities) {
10 +foreach my $key (sort keys %entities) {
11 $trie = insert_node($trie, $key, $entities{$key});
12 }
13