gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / hdf4-tirpc.patch
1 Build with libtirpc on all architectures because glibc no longer provides
2 SunRPC support.
3
4 diff --git a/configure b/configure
5 --- a/configure
6 +++ b/configure
7 @@ -23635,10 +23635,13 @@
8 *-pc-cygwin*)
9 LIBS="$LIBS -ltirpc"
10 CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc" ;;
11 + *-linux-gnu)
12 + LIBS="$LIBS -ltirpc"
13 + CPPFLAGS="$CPPFLAGS" ;;
14 *) ;;
15 esac
16
17 -if test "X$BUILD_XDR" != "Xyes"; then
18 +if test "X$BUILD_XDR" = "Xyes"; then
19 cat confdefs.h - <<_ACEOF >conftest.$ac_ext
20 /* end confdefs.h. */
21
22 @@ -23693,9 +23696,9 @@
23 ## but we need to make sure that it is present on the system. Do that here,
24 ## The SunRPC of the glibc has been replaced by a TI-RPC (Transport Independent RPC) library for IPv6 support
25 case "$host" in
26 - *-pc-cygwin*)
27 + *)
28 HAVE_RPC="yes"
29 - ac_fn_c_check_header_mongrel "$LINENO" "rpc.h" "ac_cv_header_rpc_h" "$ac_includes_default"
30 + ac_fn_c_check_header_mongrel "$LINENO" "rpc/rpc.h" "ac_cv_header_rpc_h" "$ac_includes_default"
31 if test "x$ac_cv_header_rpc_h" = xyes; then :
32 :
33 else