gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / gspell-dash-test.patch
1 Somehow, Aspell 0.60.6.1 and aspell-dict-en-2016.11.20-0 don't consider
2 this a valid spelling. Skip it.
3
4 TODO: Migrate to using hunspell. According to upstream, this bug won't be fixed.
5 See https://bugzilla.gnome.org/show_bug.cgi?id=772406.
6 --- a/testsuite/test-checker.c 2017-03-24 09:50:50.000000000 -0400
7 +++ b/testsuite/test-checker.c 2017-06-15 21:47:07.116173895 -0400
8 @@ -105,10 +105,11 @@
9 * be considered deprecated, it is better to use hunspell, so WONTFIX.
10 * For more details, see:
11 * https://bugzilla.gnome.org/show_bug.cgi?id=772406
12 + *
13 + * correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
14 + * g_assert_no_error (error);
15 + * g_assert (correctly_spelled);
16 */
17 - correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
18 - g_assert_no_error (error);
19 - g_assert (correctly_spelled);
20
21 correctly_spelled = gspell_checker_check_word (checker, "nrst-auie", -1, &error);
22 g_assert_no_error (error);