gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / gpm-glibc-2.26.patch
1 Fix building of GPM with glibc 2.26:
2
3 https://bugs.gentoo.org/629774
4
5 Patches copied from Gentoo:
6
7 https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/gpm/files/gpm-1.20.7-glibc-2.26.patch?id=1618968c56caf7f8c08823908d88dc49bb8f7649
8 https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch?id=1618968c56caf7f8c08823908d88dc49bb8f7649
9
10 --- a/src/prog/gpm-root.y 2012-10-26 17:21:38.000000000 -0400
11 +++ b/src/prog/gpm-root.y 2017-09-07 20:39:51.933264063 -0400
12 @@ -1197,7 +1197,7 @@
13 /* reap your zombies */
14 childaction.sa_handler=reap_children;
15 #if defined(__GLIBC__)
16 - __sigemptyset(&childaction.sa_mask);
17 + sigemptyset(&childaction.sa_mask);
18 #else /* __GLIBC__ */
19 childaction.sa_mask=0;
20 #endif /* __GLIBC__ */
21 From b350aee4ea5785a75cb6ad770f6b768c506ebb70 Mon Sep 17 00:00:00 2001
22 From: Mike Frysinger <vapier@gentoo.org>
23 Date: Mon, 14 Mar 2016 15:39:54 -0400
24 Subject: [PATCH] fix building w/newer glibc
25
26 Linux C libraries are looking to disentangle sysmacros.h from the
27 sys/types.h include, so make sure we pull in the header when it is
28 found.
29 ---
30 src/daemon/open_console.c | 4 ++++
31 1 file changed, 4 insertions(+)
32
33 diff --git a/src/daemon/open_console.c b/src/daemon/open_console.c
34 index 4d6c0af..6dd43e6 100644
35 --- a/src/daemon/open_console.c
36 +++ b/src/daemon/open_console.c
37 @@ -24,6 +24,10 @@
38 #include <sys/types.h> /* major() */
39 #include <sys/ioctl.h> /* ioctl */
40
41 +#ifdef HAVE_SYS_SYSMACROS_H
42 +#include <sys/sysmacros.h> /* major() w/newer glibc */
43 +#endif
44 +
45 /* Linux specific (to be outsourced in gpm2 */
46 #include <linux/serial.h> /* for serial console check */
47 #include <asm/ioctls.h> /* for serial console check */
48 --
49 2.6.2
50