gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / gnome-shell-CVE-2020-17489.patch
1 From 05b7aec747282f62212b605249d518280ff80059 Mon Sep 17 00:00:00 2001
2 From: Ray Strode <rstrode@redhat.com>
3 Date: Mon, 27 Jul 2020 10:58:22 -0400
4 Subject: [PATCH] loginDialog: Reset auth prompt on vt switch before fade in
5
6 At the moment, if a user switches to the login screen vt,
7 the login screen fades in whatever was on screen prior, and
8 then does a reset.
9
10 It makes more sense to reset first, so we fade in what the
11 user is going to interact with instead of what they interacted
12 with before.
13
14 Fixes: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2997
15 ---
16 js/gdm/loginDialog.js | 9 ++++-----
17 1 file changed, 4 insertions(+), 5 deletions(-)
18
19 diff --git a/js/gdm/loginDialog.js b/js/gdm/loginDialog.js
20 index c3f90dc58..6b35ebb16 100644
21 --- a/js/gdm/loginDialog.js
22 +++ b/js/gdm/loginDialog.js
23 @@ -920,16 +920,15 @@ var LoginDialog = GObject.registerClass({
24 if (this.opacity == 255 && this._authPrompt.verificationStatus == AuthPrompt.AuthPromptStatus.NOT_VERIFYING)
25 return;
26
27 + if (this._authPrompt.verificationStatus !== AuthPrompt.AuthPromptStatus.NOT_VERIFYING)
28 + this._authPrompt.reset();
29 +
30 this._bindOpacity();
31 this.ease({
32 opacity: 255,
33 duration: _FADE_ANIMATION_TIME,
34 mode: Clutter.AnimationMode.EASE_OUT_QUAD,
35 - onComplete: () => {
36 - if (this._authPrompt.verificationStatus != AuthPrompt.AuthPromptStatus.NOT_VERIFYING)
37 - this._authPrompt.reset();
38 - this._unbindOpacity();
39 - }
40 + onComplete: () => this._unbindOpacity(),
41 });
42 }
43
44 --
45 2.30.1
46