gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / gmp-arm-asm-nothumb.patch
1
2 # HG changeset patch
3 # User Torbjorn Granlund <tege@gmplib.org>
4 # Date 1396602422 -7200
5 # Node ID 676e2d0f0e4dd301a7066079d2c9326c25c34a40
6 # Parent 0194a75b56b21a9196626430af86c5bd9110c42d
7 Conditionalise ARM asm on !__thumb__.
8
9 diff -r 0194a75b56b2 -r 676e2d0f0e4d mpn/generic/div_qr_1n_pi1.c
10 --- a/mpn/generic/div_qr_1n_pi1.c Thu Apr 03 23:58:51 2014 +0200
11 +++ b/mpn/generic/div_qr_1n_pi1.c Fri Apr 04 11:07:02 2014 +0200
12 @@ -130,7 +130,7 @@
13 "%2" ((UDItype)(a0)), "r" ((UDItype)(b0)) __CLOBBER_CC)
14 #endif
15
16 -#if defined (__arm__) && W_TYPE_SIZE == 32
17 +#if defined (__arm__) && !defined (__thumb__) && W_TYPE_SIZE == 32
18 #define add_mssaaaa(m, sh, sl, ah, al, bh, bl) \
19 __asm__ ( "adds %2, %5, %6\n\t" \
20 "adcs %1, %3, %4\n\t" \
21