gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / glibc-supported-locales.patch
1 This patch is taken from debian's glibc package (generate-supported.mk).
2 It install the localedata/SUPPORTED file of the glibc. This file lists
3 all the supported locales of the glibc.
4
5 diff --git a/localedata/Makefile b/localedata/Makefile
6 --- a/localedata/Makefile
7 +++ b/localedata/Makefile
8 @@ -176,7 +176,8 @@
9 else
10 install-others := $(addprefix $(inst_i18ndir)/, \
11 $(addsuffix .gz, $(charmaps)) \
12 - $(locales))
13 + $(locales)) \
14 + $(inst_i18ndir)/SUPPORTED
15 endif
16
17 tests: $(objdir)/iconvdata/gconv-modules
18 @@ -401,6 +402,14 @@
19
20 include SUPPORTED
21
22 +$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
23 + for locale in $(SUPPORTED-LOCALES); do \
24 + [ $$locale = true ] && continue; \
25 + echo $$locale | sed 's,/, ,' >> LOCALES; \
26 + done
27 + $(make-target-directory)
28 + $(INSTALL_DATA) LOCALES $@
29 +
30 INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES))
31 INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES))
32