gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / glibc-2.28-supported-locales.patch
1 This patch is taken from debian's glibc package (generate-supported.mk).
2 It install the localedata/SUPPORTED file of the glibc. This file lists
3 all the supported locales of the glibc.
4
5 diff --git a/localedata/Makefile.old b/localedata/Makefile
6 index 34877c0..a61d9b9 100644
7 --- a/localedata/Makefile.old
8 +++ b/localedata/Makefile
9 @@ -91,7 +91,8 @@ endif
10 # Files to install.
11 install-others := $(addprefix $(inst_i18ndir)/, \
12 $(addsuffix .gz, $(charmaps)) \
13 - $(locales))
14 + $(locales)) \
15 + $(inst_i18ndir)/SUPPORTED
16
17 tests: $(objdir)/iconvdata/gconv-modules
18
19 @@ -195,6 +196,14 @@ endif
20
21 include SUPPORTED
22
23 +$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
24 + for locale in $(SUPPORTED-LOCALES); do \
25 + [ $$locale = true ] && continue; \
26 + echo $$locale | sed 's,/, ,' >> LOCALES; \
27 + done
28 + $(make-target-directory)
29 + $(INSTALL_DATA) LOCALES $@
30 +
31 INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
32
33 # Sometimes the whole collection of locale files should be installed.