gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ghostscript-no-header-creationdate.patch
1 This patch makes emission of /CreationDate and /ModDate headers optional.
2
3 If the environment variable GS_GENERATE_UUIDS is set to "0" or "no", it will
4 not write out the "/ID" field (if that's permissible).
5
6 Upstream does not want to do this.
7
8 See: https://bugs.ghostscript.com/show_bug.cgi?id=698208
9 diff --git a/orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c b/bb/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
10 index 0fb067e..b342e2c 100644
11 --- orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
12 +++ gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
13 @@ -305,6 +305,9 @@ pdf_initialize_ids(gx_device_pdf * pdev)
14 * date and time, rather than (for example) %%CreationDate from the
15 * PostScript file. We think this is wrong, but we do the same.
16 */
17 + if (!getenv("GS_GENERATE_UUIDS") ||
18 + (strcasecmp(getenv("GS_GENERATE_UUIDS"), "0") != 0 &&
19 + strcasecmp(getenv("GS_GENERATE_UUIDS"), "no") != 0))
20 {
21 struct tm tms;
22 time_t t;