gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ghc-pandoc-fix-html-tests.patch
1 This patch is taken from upstream. It fixes two HTML tests that are broken
2 due to using a Skylighting version greater than or equal to 0.8.2.
3
4 From 968d2046a3cb6db661673be580660ac402753c34 Mon Sep 17 00:00:00 2001
5 From: John MacFarlane <jgm@berkeley.edu>
6 Date: Sun, 14 Jul 2019 10:48:14 -0700
7 Subject: [PATCH] Update test for new skylighting.
8
9 ---
10 test/lhs-test.html | 13 ++++++-------
11 test/lhs-test.html+lhs | 13 ++++++-------
12 2 files changed, 12 insertions(+), 14 deletions(-)
13
14 diff --git a/test/lhs-test.html b/test/lhs-test.html
15 index 6685555f4..446dd3d95 100644
16 --- a/test/lhs-test.html
17 +++ b/test/lhs-test.html
18 @@ -12,19 +12,18 @@
19 div.column{display: inline-block; vertical-align: top; width: 50%;}
20 </style>
21 <style>
22 -code.sourceCode > span { display: inline-block; line-height: 1.25; }
23 +pre > code.sourceCode { white-space: pre; position: relative; }
24 +pre > code.sourceCode > span { display: inline-block; line-height: 1.25; }
25 +pre > code.sourceCode > span:empty { height: 1.2em; }
26 code.sourceCode > span { color: inherit; text-decoration: inherit; }
27 -code.sourceCode > span:empty { height: 1.2em; }
28 -.sourceCode { overflow: visible; }
29 -code.sourceCode { white-space: pre; position: relative; }
30 div.sourceCode { margin: 1em 0; }
31 pre.sourceCode { margin: 0; }
32 @media screen {
33 div.sourceCode { overflow: auto; }
34 }
35 @media print {
36 -code.sourceCode { white-space: pre-wrap; }
37 -code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
38 +pre > code.sourceCode { white-space: pre-wrap; }
39 +pre > code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
40 }
41 pre.numberSource code
42 { counter-reset: source-line 0; }
43 @@ -44,7 +43,7 @@ pre.numberSource { margin-left: 3em; border-left: 1px solid #aaaaaa; padding-le
44 div.sourceCode
45 { }
46 @media screen {
47 -code.sourceCode > span > a:first-child::before { text-decoration: underline; }
48 +pre > code.sourceCode > span > a:first-child::before { text-decoration: underline; }
49 }
50 code span.al { color: #ff0000; font-weight: bold; } /* Alert */
51 code span.an { color: #60a0b0; font-weight: bold; font-style: italic; } /* Annotation */
52 diff --git a/test/lhs-test.html+lhs b/test/lhs-test.html+lhs
53 index e57dfc105..a5cdb0245 100644
54 --- a/test/lhs-test.html+lhs
55 +++ b/test/lhs-test.html+lhs
56 @@ -12,19 +12,18 @@
57 div.column{display: inline-block; vertical-align: top; width: 50%;}
58 </style>
59 <style>
60 -code.sourceCode > span { display: inline-block; line-height: 1.25; }
61 +pre > code.sourceCode { white-space: pre; position: relative; }
62 +pre > code.sourceCode > span { display: inline-block; line-height: 1.25; }
63 +pre > code.sourceCode > span:empty { height: 1.2em; }
64 code.sourceCode > span { color: inherit; text-decoration: inherit; }
65 -code.sourceCode > span:empty { height: 1.2em; }
66 -.sourceCode { overflow: visible; }
67 -code.sourceCode { white-space: pre; position: relative; }
68 div.sourceCode { margin: 1em 0; }
69 pre.sourceCode { margin: 0; }
70 @media screen {
71 div.sourceCode { overflow: auto; }
72 }
73 @media print {
74 -code.sourceCode { white-space: pre-wrap; }
75 -code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
76 +pre > code.sourceCode { white-space: pre-wrap; }
77 +pre > code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
78 }
79 pre.numberSource code
80 { counter-reset: source-line 0; }
81 @@ -44,7 +43,7 @@ pre.numberSource { margin-left: 3em; border-left: 1px solid #aaaaaa; padding-le
82 div.sourceCode
83 { }
84 @media screen {
85 -code.sourceCode > span > a:first-child::before { text-decoration: underline; }
86 +pre > code.sourceCode > span > a:first-child::before { text-decoration: underline; }
87 }
88 code span.al { color: #ff0000; font-weight: bold; } /* Alert */
89 code span.an { color: #60a0b0; font-weight: bold; font-style: italic; } /* Annotation */
90 --
91 2.23.0
92