gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / genimage-signedness.patch
1 commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
2 Author: Timotej Lazar <timotej.lazar@araneo.si>
3 Date: Wed Aug 19 19:36:02 2020 +0200
4
5 test: normalize flags reported by dumpe2fs
6
7 Filesystem flags depend on the system – usually signed_directory_hash,
8 but unsigned_directory_hash at least on arm64.
9
10 Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
11
12 diff --git a/test/basic-images.test b/test/basic-images.test
13 index f6685e1..cb104c3 100755
14 --- a/test/basic-images.test
15 +++ b/test/basic-images.test
16 @@ -158,6 +158,8 @@ check_ext() {
17 # format change
18 csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
19 dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
20 + # some architectures (including arm64) use unsigned char
21 + sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
22 # fixup for ext3 journal size with old tune2fs
23 sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
24 # output format changed with some version