gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ganeti-deterministic-manual.patch
1 Sort the ecode list in the gnt-cluster manual for deterministic results.
2
3 Submitted upstream: <https://github.com/ganeti/ganeti/pull/1504>.
4
5 diff --git a/lib/build/sphinx_ext.py b/lib/build/sphinx_ext.py
6 --- a/lib/build/sphinx_ext.py
7 +++ b/lib/build/sphinx_ext.py
8 @@ -108,7 +108,7 @@ CV_ECODES_DOC = "ecodes"
9 # pylint: disable=W0621
10 CV_ECODES_DOC_LIST = [(name, doc) for (_, name, doc) in constants.CV_ALL_ECODES]
11 DOCUMENTED_CONSTANTS = {
12 - CV_ECODES_DOC: CV_ECODES_DOC_LIST,
13 + CV_ECODES_DOC: sorted(CV_ECODES_DOC_LIST, key=lambda tup: tup[0]),
14 }
15
16