gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / fifengine-swig-compat.patch
1 Fix build failure when using Swig 4.
2
3 Taken from upstream:
4 https://github.com/fifengine/fifengine/commit/d14f232f4cd9a00b05d6872957070e8c020f515d
5
6 diff --git a/CMakeLists.txt b/CMakeLists.txt
7 --- a/CMakeLists.txt
8 +++ b/CMakeLists.txt
9 @@ -893,7 +893,7 @@ if(build-python)
10 find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
11 include_directories(${PYTHON_INCLUDE_PATH})
12
13 - set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
14 + set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314)
15
16 set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
17 set(FIFE_SOURCES ${FIFE_CORE_SRC})