gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / emacs-exwm-fix-fullscreen-states.patch
1 From edb930005b0ba83051ca8a59b493e9a3c8ef580a Mon Sep 17 00:00:00 2001
2 From: Chris Feng <chris.w.feng@gmail.com>
3 Date: Sun, 14 Jun 2020 00:00:00 +0000
4 Subject: [PATCH] Fix fullscreen states
5
6 * exwm-layout.el (exwm-layout-set-fullscreen,
7 exwm-layout-unset-fullscreen): Use `exwm--id' for interactive use.
8 (exwm-layout-unset-fullscreen): Mandatorily clear fullscreen states.
9 ---
10 exwm-layout.el | 6 ++++--
11 1 file changed, 4 insertions(+), 2 deletions(-)
12
13 diff --git a/exwm-layout.el b/exwm-layout.el
14 index 170c2be..79d0c95 100644
15 --- a/exwm-layout.el
16 +++ b/exwm-layout.el
17 @@ -205,7 +205,7 @@
18 :border-width 0
19 :stack-mode xcb:StackMode:Above))
20 (cl-pushnew xcb:Atom:_NET_WM_STATE_FULLSCREEN exwm--ewmh-state)
21 - (exwm-layout--set-ewmh-state id)
22 + (exwm-layout--set-ewmh-state exwm--id)
23 (xcb:flush exwm--connection)
24 (set-window-dedicated-p (get-buffer-window) t)
25 (exwm-input--release-keyboard exwm--id)))
26 @@ -233,7 +233,9 @@
27 (let ((window (get-buffer-window nil t)))
28 (when window
29 (exwm-layout--show exwm--id window))))
30 - (exwm-layout--set-ewmh-state id)
31 + (setq exwm--ewmh-state
32 + (delq xcb:Atom:_NET_WM_STATE_FULLSCREEN exwm--ewmh-state))
33 + (exwm-layout--set-ewmh-state exwm--id)
34 (xcb:flush exwm--connection)
35 (set-window-dedicated-p (get-buffer-window) nil)
36 (when (eq 'line-mode exwm--selected-input-mode)
37 --
38 2.26.2
39