gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / doc++-include-directives.patch
1 Adapted from https://sourceforge.net/p/docpp/patches/1/
2
3 --- doc++-3.4.10/src/comment.ll 2000-06-24 18:50:23.000000000 +0200
4 +++ doc++-3.4.10/src/comment.ll 2012-09-17 11:14:50.744922841 +0200
5 @@ -24,7 +24,7 @@
6
7 #include <assert.h>
8 #include <ctype.h>
9 -#include <iostream.h>
10 +#include <iostream>
11 #include <stdarg.h>
12 #include <stdio.h>
13
14 --- doc++-3.4.10/src/cpp.ll 2002-05-09 08:11:14.000000000 +0200
15 +++ doc++-3.4.10/src/cpp.ll 2012-09-17 11:15:21.184333236 +0200
16 @@ -26,7 +26,7 @@
17
18 #include <assert.h>
19 #include <ctype.h>
20 -#include <iostream.h>
21 +#include <iostream>
22 #include <stdarg.h>
23 #include <stdio.h>
24
25 --- doc++-3.4.10/src/datahashtable.h 2000-08-27 21:44:34.000000000 +0200
26 +++ doc++-3.4.10/src/datahashtable.h 2012-09-17 11:22:59.442589960 +0200
27 @@ -26,11 +26,13 @@
28 #define _DATAHASHTABLE_H
29
30 #include <assert.h>
31 -#include <iostream.h>
32 +#include <iostream>
33 #include <stdlib.h>
34
35 #include "McDArray.h"
36
37 +using namespace std;
38 +
39 /* This should be a private subclass of #DataHashTable#. However, since cfront
40 is not able to compile this constrution, we had move the class to global
41 scope.
42 --- doc++-3.4.10/src/doc2dbsgml.ll 2002-05-09 08:11:14.000000000 +0200
43 +++ doc++-3.4.10/src/doc2dbsgml.ll 2012-09-17 11:20:49.077259414 +0200
44 @@ -22,8 +22,8 @@
45
46 %{
47 #include <assert.h>
48 -#include <fstream.h>
49 -#include <iostream.h>
50 +#include <fstream>
51 +#include <iostream>
52 #include <stdio.h>
53 #include <stdlib.h>
54 #include <string.h>
55 @@ -36,6 +36,8 @@
56 #undef YY_INPUT
57 #define YY_INPUT(buf, result, max_size) result = yyread(buf, max_size);
58
59 +using namespace std;
60 +
61 static Entry* current;
62 static int inPos;
63 static int lastContext;
64 --- doc++-3.4.10/src/doc2dbxml.ll 2002-05-09 08:11:14.000000000 +0200
65 +++ doc++-3.4.10/src/doc2dbxml.ll 2012-09-17 11:20:22.264831159 +0200
66 @@ -25,8 +25,8 @@
67
68 %{
69 #include <assert.h>
70 -#include <fstream.h>
71 -#include <iostream.h>
72 +#include <fstream>
73 +#include <iostream>
74 #include <stdio.h>
75 #include <stdlib.h>
76 #include <string.h>
77 @@ -39,6 +39,8 @@
78 #undef YY_INPUT
79 #define YY_INPUT(buf, result, max_size) result = yyread(buf, max_size);
80
81 +using namespace std;
82 +
83 static Entry* current;
84 static int inPos;
85 static int lastContext;
86 --- doc++-3.4.10/src/doc2html.ll 2000-07-17 23:17:24.000000000 +0200
87 +++ doc++-3.4.10/src/doc2html.ll 2012-09-17 11:22:40.354469631 +0200
88 @@ -29,6 +29,8 @@
89 #include "doc.h"
90 #include "nametable.h"
91
92 +using namespace std;
93 +
94 extern NameTable gifs;
95
96 #define YY_DECL int yylex()
97 --- doc++-3.4.10/src/doc2tex.ll 2000-11-05 17:21:16.000000000 +0100
98 +++ doc++-3.4.10/src/doc2tex.ll 2012-09-17 11:23:22.210701715 +0200
99 @@ -23,8 +23,8 @@
100
101 %{
102 #include <assert.h>
103 -#include <fstream.h>
104 -#include <iostream.h>
105 +#include <fstream>
106 +#include <iostream>
107 #include <stdio.h>
108 #include <stdlib.h>
109 #include <string.h>
110 @@ -38,6 +38,8 @@
111 #undef YY_INPUT
112 #define YY_INPUT(buf, result, max_size) result = yyread(buf, max_size);
113
114 +using namespace std;
115 +
116 static Entry* current;
117 static int inPos;
118 static int lastContext;
119 --- doc++-3.4.10/src/doc.ll 2000-09-17 21:41:17.000000000 +0200
120 +++ doc++-3.4.10/src/doc.ll 2012-09-17 11:15:37.068009454 +0200
121 @@ -23,8 +23,8 @@
122
123 %{
124 #include <assert.h>
125 -#include <fstream.h>
126 -#include <iostream.h>
127 +#include <fstream>
128 +#include <iostream>
129 #include <stdio.h>
130 #include <stdlib.h>
131 #include <string.h>
132 --- doc++-3.4.10/src/equate.cc 2002-05-02 21:13:10.000000000 +0200
133 +++ doc++-3.4.10/src/equate.cc 2012-09-17 11:25:42.850669366 +0200
134 @@ -23,9 +23,9 @@
135
136 #include "config.h"
137
138 -#include <fstream.h>
139 +#include <fstream>
140 #include <getopt.h>
141 -#include <iostream.h>
142 +#include <iostream>
143 #include <stdio.h>
144 #include <string.h>
145
146 --- doc++-3.4.10/src/html.cc 2001-02-17 07:34:49.000000000 +0100
147 +++ doc++-3.4.10/src/html.cc 2012-09-17 11:24:07.978824681 +0200
148 @@ -31,7 +31,7 @@
149 #include <direct.h>
150 #endif
151 #include <errno.h>
152 -#include <iostream.h>
153 +#include <iostream>
154 #include <stdio.h>
155 #include <stdlib.h>
156 #include <string.h>
157 --- doc++-3.4.10/src/java.ll 2001-11-25 18:04:12.000000000 +0100
158 +++ doc++-3.4.10/src/java.ll 2012-09-17 11:24:19.138834603 +0200
159 @@ -26,7 +26,7 @@
160
161 #include <assert.h>
162 #include <ctype.h>
163 -#include <iostream.h>
164 +#include <iostream>
165 #include <stdio.h>
166
167 #include "doc.h"
168 --- doc++-3.4.10/src/main.cc 2002-05-09 08:11:14.000000000 +0200
169 +++ doc++-3.4.10/src/main.cc 2012-09-17 11:25:30.650719070 +0200
170 @@ -25,7 +25,7 @@
171 #include "config.h"
172
173 #include <assert.h>
174 -#include <fstream.h>
175 +#include <fstream>
176 #include <getopt.h>
177 #include <locale.h>
178 #include <stdio.h>
179 --- doc++-3.4.10/src/nametable.cc 2000-04-08 23:11:54.000000000 +0200
180 +++ doc++-3.4.10/src/nametable.cc 2012-09-17 11:25:58.894591128 +0200
181 @@ -22,7 +22,7 @@
182 */
183
184 #include <assert.h>
185 -#include <iostream.h>
186 +#include <iostream>
187 #include <stdlib.h>
188 #include <string.h>
189
190 --- doc++-3.4.10/src/nametable.h 2000-04-08 23:11:56.000000000 +0200
191 +++ doc++-3.4.10/src/nametable.h 2012-09-17 11:22:07.826207198 +0200
192 @@ -25,7 +25,7 @@
193 #define _NAME_TABLE_H
194
195 #include <assert.h>
196 -#include <iostream.h>
197 +#include <iostream>
198
199 #include "datahashtable.h"
200
201 --- doc++-3.4.10/src/php.ll 2001-02-16 23:34:47.000000000 +0100
202 +++ doc++-3.4.10/src/php.ll 2012-09-17 11:25:18.582759801 +0200
203 @@ -23,7 +23,7 @@
204 %{
205 #include <assert.h>
206 #include <ctype.h>
207 -#include <iostream.h>
208 +#include <iostream>
209 #include <stdio.h>
210
211 #include "doc.h"
212 --- doc++-3.4.10/src/tex2gif.cc 2001-08-07 20:55:40.000000000 +0200
213 +++ doc++-3.4.10/src/tex2gif.cc 2012-09-17 11:26:06.698547836 +0200
214 @@ -21,8 +21,8 @@
215 Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
216 */
217
218 -#include <iostream.h>
219 -#include <fstream.h>
220 +#include <iostream>
221 +#include <fstream>
222 #include <stdio.h>
223 #include <string.h>
224