gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / datefudge-gettimeofday.patch
1 Add the 'restrict' qualifier to match the 'gettimeofday' declaration found
2 in glibc 2.31.
3
4 --- datefudge-1.23/datefudge.c 2020-02-17 22:35:21.343341725 +0100
5 +++ datefudge-1.23/datefudge.c 2020-02-17 22:35:49.619117874 +0100
6 @@ -78,6 +78,6 @@
7 return 0;
8 }
9
10 -int gettimeofday(struct timeval *x, struct timezone *y) {
11 +int gettimeofday(struct timeval *restrict x, void *restrict y) {
12 return __gettimeofday(x,y);
13 }